NVIDIA
GRID K2 on HP Gen8 XenServer 7.0 "An emulator required to run this VM failed to start"
I have the following setup, which works fine in direct pass-through mode, i.e. 1-1 GPU to VDI, however if I select any of the K profiles (K280Q, K260Q etc.) then I can only power on a single VDI. When the next VDI is started then it fails to boot with the error "An emulator required to run this VM failed to start" Haven't done much troubleshooting so far, just wanted to post something quickly in case anyone had a quick fix for this. Really annoying as all looked so promising with direct 1-1 pass through before I licenced XenServer and the new profiles became available (the additional profiles are a 'premium' feature requiring licencing). HP Proliant WS460c Gen8 WS Blade HP BIOS I31 06/01/2015 (Setup Mode/Max Performance Profile) HP SW 460 Expansion Blade containing: NVIDIA GK104GL GRID K2 Driver Version 361.45.09 XenServer 7.0 XenDesktop 7.9 Thanks, Darren
I have the following setup, which works fine in direct pass-through mode, i.e. 1-1 GPU to VDI, however if I select any of the K profiles (K280Q, K260Q etc.) then I can only power on a single VDI. When the next VDI is started then it fails to boot with the error "An emulator required to run this VM failed to start"

Haven't done much troubleshooting so far, just wanted to post something quickly in case anyone had a quick fix for this. Really annoying as all looked so promising with direct 1-1 pass through before I licenced XenServer and the new profiles became available (the additional profiles are a 'premium' feature requiring licencing).


HP Proliant WS460c Gen8 WS Blade
HP BIOS I31 06/01/2015 (Setup Mode/Max Performance Profile)
HP SW 460 Expansion Blade containing:
NVIDIA GK104GL GRID K2
Driver Version 361.45.09
XenServer 7.0
XenDesktop 7.9

Thanks,
Darren

#1
Posted 10/28/2016 10:19 AM   
Hmm, I now see that my configuration does not appear to be officially supported: http://hcl.xenserver.org/gpus/1/Nvidia_GRID_K2 HP ProLiant WS460c Gen8, latest XenServer mentioned is 6.5.0, but only for Passthrough, not vGPU with a K2.
Hmm, I now see that my configuration does not appear to be officially supported:


http://hcl.xenserver.org/gpus/1/Nvidia_GRID_K2


HP ProLiant WS460c Gen8, latest XenServer mentioned is 6.5.0, but only for Passthrough, not vGPU with a K2.

#2
Posted 10/28/2016 12:56 PM   
Might be worth asking on the XenServer forums: http://discussions.citrix.com/topic/378788-vms-failing-to-power-on-with-xenserver-7-using-dell-per720-and-nvidia-k1/ Although that specific server and verison of XS not on the HCL, very similar combinations have been.... Might also be worth enquiring with XenServer HCL as it's possible there is a know issue that means it's not supported...
Might be worth asking on the XenServer forums: http://discussions.citrix.com/topic/378788-vms-failing-to-power-on-with-xenserver-7-using-dell-per720-and-nvidia-k1/


Although that specific server and verison of XS not on the HCL, very similar combinations have been....

Might also be worth enquiring with XenServer HCL as it's possible there is a know issue that means it's not supported...

#3
Posted 10/28/2016 05:05 PM   
Might be worth asking on the XenServer forums: http://discussions.citrix.com/topic/378788-vms-failing-to-power-on-with-xenserver-7-using-dell-per720-and-nvidia-k1/ Although that specific server and verison of XS not on the HCL, very similar combinations have been.... Might also be worth enquiring with XenServer HCL as it's possible there is a know issue that means it's not supported...
Might be worth asking on the XenServer forums: http://discussions.citrix.com/topic/378788-vms-failing-to-power-on-with-xenserver-7-using-dell-per720-and-nvidia-k1/


Although that specific server and verison of XS not on the HCL, very similar combinations have been....

Might also be worth enquiring with XenServer HCL as it's possible there is a know issue that means it's not supported...

#4
Posted 10/28/2016 05:05 PM   
Thanks Rachel, I have done as you suggest and posted in the Citrix forums. http://discussions.citrix.com/topic/382259-nvidia-grid-k2-on-hp-gen8-xenserver-70-an-emulator-required-to-run-this-vm-failed-to-start/

#5
Posted 11/01/2016 09:32 AM   
Scroll To Top

Add Reply