Artificial Intelligence Computing Leadership from NVIDIA
Enable virtual display with K1 (NVSMI showing "Display Mode:Disabled")
So I have 2 GRID K1 cards. The first one when passing through to a VM has a "Generic Non-PnP Monitor" attached to the K1. The nvidia control panel shows it as a VGA monitor. Now I have a second K1 card with slightly different firmware, which doesn't have this monitor, and I can't open the nvidia control panel, as it requires a monitor in order to open. Digging deeper I queried both adapters with nvsmi (nvidia-smi.exe -q) and found that on the first card, "Display Mode" and "Display Active" are both set to enabled, while on the card with no virtual monitor it has them disabled. This appears to be the setting that controls whether a virtual monitor appears. The problem is, I can't for the life of me find out how to change this setting. My workload depends on a "real" monitor being attached. I've even tried different driver versions. I'm using KVM on debian. Any help is appreciated
So I have 2 GRID K1 cards. The first one when passing through to a VM has a "Generic Non-PnP Monitor" attached to the K1. The nvidia control panel shows it as a VGA monitor.

Now I have a second K1 card with slightly different firmware, which doesn't have this monitor, and I can't open the nvidia control panel, as it requires a monitor in order to open.

Digging deeper I queried both adapters with nvsmi (nvidia-smi.exe -q) and found that on the first card, "Display Mode" and "Display Active" are both set to enabled, while on the card with no virtual monitor it has them disabled. This appears to be the setting that controls whether a virtual monitor appears.

The problem is, I can't for the life of me find out how to change this setting. My workload depends on a "real" monitor being attached. I've even tried different driver versions.

I'm using KVM on debian. Any help is appreciated

#1
Posted 10/12/2019 10:55 AM   
Scroll To Top

Add Reply