NVIDIA
NVIDIA Vmware vSphere-6.5
Thank you! This resolved our issue.
Thank you! This resolved our issue.

#16
Posted 10/17/2017 04:01 PM   
[quote="jmain"]vSphere 6.5 and November 2016 GRID drivers (both Kepler and Maxwell) require changing the default GPU mode from “Shared” (vSGA) to “Shared Direct” (vGPU) via vCenter to enable vGPU support for VMs. Not changing this will result in the VMs with a vGPU profile assigned to not start with the standard “graphics resources not available” error. For those that may be starting to evaluate the November 2016 GRID drivers with vSphere 6.5, an additional step to configure the GPU mode is required. Procedure: - Select the ESXi 6.5 host in vCenter 6.5, next select the “Configure” tab and scroll down to “Graphics”. - Highlight each GPUs that you want to use for vGPU and then select the edit icon to modify the Graphics device settings. - Select “Shared Direct” for vGPU - The host will need to be rebooted for the changes to take effect, after that your vGPU VMs should now start normally. This new requirement and procedures will ba added to the documentation shortly, thank you for reporting this issue.[/quote] I performed this extra step, rebooted and my vm is still not powering on and giving the error "graphics resource not available". Any suggestions? Which documentation outlines these steps btw?
jmain said:vSphere 6.5 and November 2016 GRID drivers (both Kepler and Maxwell) require changing the default GPU mode from “Shared” (vSGA) to “Shared Direct” (vGPU) via vCenter to enable vGPU support for VMs.

Not changing this will result in the VMs with a vGPU profile assigned to not start with the standard “graphics resources not available” error.

For those that may be starting to evaluate the November 2016 GRID drivers with vSphere 6.5, an additional step to configure the GPU mode is required.

Procedure:
- Select the ESXi 6.5 host in vCenter 6.5, next select the “Configure” tab and scroll down to “Graphics”.
- Highlight each GPUs that you want to use for vGPU and then select the edit icon to modify the Graphics device settings.
- Select “Shared Direct” for vGPU
- The host will need to be rebooted for the changes to take effect, after that your vGPU VMs should now start normally.

This new requirement and procedures will ba added to the documentation shortly, thank you for reporting this issue.


I performed this extra step, rebooted and my vm is still not powering on and giving the error "graphics resource not available". Any suggestions? Which documentation outlines these steps btw?

#17
Posted 11/09/2017 09:16 PM   
Ok. I'm getting conflicting info. Should the Tesla M60 GPU card be in PCI passthrough on the ESXi host, or should it not be, in order for vGPU to work? GRID requirements use to state GPU passthrough, but what about Tesla M60? Does the VIB take care of all of that? When I place into passthrough I now notice xorg won't start and nvidia-smi complains of an initialization error. So, what's the correct procedures for ESXi 6.5 with Tesla M60 and Horizon View 7.3 in order to utilize vGPU?
Ok. I'm getting conflicting info. Should the Tesla M60 GPU card be in PCI passthrough on the ESXi host, or should it not be, in order for vGPU to work? GRID requirements use to state GPU passthrough, but what about Tesla M60? Does the VIB take care of all of that? When I place into passthrough I now notice xorg won't start and nvidia-smi complains of an initialization error.
So, what's the correct procedures for ESXi 6.5 with Tesla M60 and Horizon View 7.3 in order to utilize vGPU?

#18
Posted 11/09/2017 09:33 PM   
For sure you can't run the GPU in PCI Passthrough if you want to use vGPU.
For sure you can't run the GPU in PCI Passthrough if you want to use vGPU.

#19
Posted 11/10/2017 03:52 AM   
Scroll To Top

Add Reply