Artificial Intelligence Computing Leadership from NVIDIA
trying to get some sample applications to work
Hello, I am trying to get some of the samples to work in the cuda toolkit. some/most work how I use them. However, I am using X11 forwarding, and for example the Mandelbrot sample code throws me an error: $ /usr/local/cuda-10.2/samples/bin/x86_64/linux/release/Mandelbrot [CUDA Mandelbrot/Julia Set] - Starting... GPU Device 0: "Kepler" with compute capability 3.0 Data initialization done. Initializing GLUT... OpenGL window created. Creating GL texture... Texture created. Creating PBO... CUDA error at Mandelbrot.cpp:971 code=999(cudaErrorUnknown) "cudaGraphicsGLRegisterBuffer(&cuda_pbo_resource, gl_PBO, cudaGraphicsMapFlagsWriteDiscard)" I assume that is because I am doing X11 forwarding, "is there a way around it?" thanks, Ron
Hello,

I am trying to get some of the samples to work in the cuda toolkit. some/most work how I use them.

However, I am using X11 forwarding, and for example the Mandelbrot sample code throws me an error:

$ /usr/local/cuda-10.2/samples/bin/x86_64/linux/release/Mandelbrot
[CUDA Mandelbrot/Julia Set] - Starting...
GPU Device 0: "Kepler" with compute capability 3.0

Data initialization done.
Initializing GLUT...
OpenGL window created.
Creating GL texture...
Texture created.
Creating PBO...
CUDA error at Mandelbrot.cpp:971 code=999(cudaErrorUnknown) "cudaGraphicsGLRegisterBuffer(&cuda_pbo_resource, gl_PBO, cudaGraphicsMapFlagsWriteDiscard)"


I assume that is because I am doing X11 forwarding, "is there a way around it?"

thanks,

Ron

#1
Posted 02/14/2020 05:14 AM   
Scroll To Top

Add Reply