Artificial Intelligence Computing Leadership from NVIDIA
ESXi 6.5su3, NVIDIA P4 no PCI shared device
Problem: In ESXi (No vCenter) when I create a Linux VM (Ubuntu 18.04), I can't see the PCI Shared device nor vGPU profiles. I'm accessing from Web client, not sure what I'm missing? [b]Server model[/b] Dell Inc. Model PowerEdge R640 CPU 28 CPUs x Intel(R) Xeon(R) Gold 5120 CPU @ 2.20GHz NVIDIA P4 [b]Hypervisor[/b] ESXi server No VCenter ESXi 6.5.0 Update 3 (Build 13932383) I installed: NVIDIA-VMware_ESXi_6.5_Host_Driver-430.67-1OEM.650.0.0.4598673.x86_64.vib I can see the driver via nvidia-smi [code] nvidia-smi Wed Feb 19 00:12:24 2020 +-----------------------------------------------------------------------------+ | NVIDIA-SMI 430.67 Driver Version: 430.67 CUDA Version: N/A | |-------------------------------+----------------------+----------------------+ | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC | | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. | |===============================+======================+======================| | 0 Tesla P4 On | 00000000:5E:00.0 Off | Off | | N/A 53C P8 12W / 75W | 21MiB / 8191MiB | 0% Default | +-------------------------------+----------------------+----------------------+ +-----------------------------------------------------------------------------+ | Processes: GPU Memory | | GPU PID Type Process name Usage | |=============================================================================| | No running processes found | +-----------------------------------------------------------------------------+[/code] I'm using this guide: 430.67-430.63-432.08-grid-software-quick-start-guide.pdf [code]vmkload_mod -l | grep nvidia nvidia 13 18080 [/code] [code]nvidia-smi vgpu Wed Feb 19 00:38:43 2020 +-----------------------------------------------------------------------------+ | NVIDIA-SMI 430.67 Driver Version: 430.67 | |---------------------------------+------------------------------+------------+ | GPU Name | Bus-Id | GPU-Util | | vGPU ID Name | VM ID VM Name | vGPU-Util | |=================================+==============================+============| | 0 Tesla P4 | 00000000:5E:00.0 | 0% | +---------------------------------+------------------------------+------------+ [/code]
Problem:

In ESXi (No vCenter) when I create a Linux VM (Ubuntu 18.04), I can't see the PCI Shared device nor vGPU profiles.
I'm accessing from Web client, not sure what I'm missing?

Server model

Dell Inc.
Model PowerEdge R640
CPU 28 CPUs x Intel(R) Xeon(R) Gold 5120 CPU @ 2.20GHz
NVIDIA P4

Hypervisor

ESXi server No VCenter
ESXi 6.5.0 Update 3 (Build 13932383)

I installed: NVIDIA-VMware_ESXi_6.5_Host_Driver-430.67-1OEM.650.0.0.4598673.x86_64.vib
I can see the driver via nvidia-smi

nvidia-smi
Wed Feb 19 00:12:24 2020
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 430.67 Driver Version: 430.67 CUDA Version: N/A |
|-------------------------------+----------------------+----------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 Tesla P4 On | 00000000:5E:00.0 Off | Off |
| N/A 53C P8 12W / 75W | 21MiB / 8191MiB | 0% Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| No running processes found |
+-----------------------------------------------------------------------------+


I'm using this guide: 430.67-430.63-432.08-grid-software-quick-start-guide.pdf

vmkload_mod -l | grep nvidia
nvidia 13 18080



nvidia-smi vgpu
Wed Feb 19 00:38:43 2020
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 430.67 Driver Version: 430.67 |
|---------------------------------+------------------------------+------------+
| GPU Name | Bus-Id | GPU-Util |
| vGPU ID Name | VM ID VM Name | vGPU-Util |
|=================================+==============================+============|
| 0 Tesla P4 | 00000000:5E:00.0 | 0% |
+---------------------------------+------------------------------+------------+

#1
Posted 02/19/2020 05:56 AM   
Scroll To Top

Add Reply