Artificial Intelligence Computing Leadership from NVIDIA
Confused on versioning...
I currently have NVIDIA vGPU version 9.1 installed on all hosts. I am looking to update them but very confused on version numbers. Currently running vSphere 6.7 so I am sorted by that in that Software Downloads section but the VGPU versions are all over the place. Why was version 7.5 released AFTER 9.1? Now most recently 8.3 is available but the previous version before that was 10.1. Do I want to stay on the 9.x versions? Can I go directly to 10.1? Or should I go to 8.3 since it's the newest? What version do I download to be most up to date? [img]https://i.imgur.com/4nfD3mY.jpg[/img] EDIT: Sorry for the terrible image quality ¯\_(?)_/¯
I currently have NVIDIA vGPU version 9.1 installed on all hosts. I am looking to update them but very confused on version numbers.

Currently running vSphere 6.7 so I am sorted by that in that Software Downloads section but the VGPU versions are all over the place. Why was version 7.5 released AFTER 9.1? Now most recently 8.3 is available but the previous version before that was 10.1. Do I want to stay on the 9.x versions? Can I go directly to 10.1? Or should I go to 8.3 since it's the newest? What version do I download to be most up to date?

Image


EDIT: Sorry for the terrible image quality ¯\_(?)_/¯

#1
Posted 02/28/2020 06:52 PM   
Hi I could answer this with a one line response, but it's better to explain ... NVIDIA maintain and support multiple driver branches. Therefore, different driver branches will have updated releases at different times. The drivers come in two versions: "Long-Term Support Branch" (LTSB, sometimes referred to as LTSR (R=Release) same thing, different acronym), and the other is what's known as "Current Release" (CR). NVIDIA will [i]typically[/i] support three different branches concurrently, one LTSB and two CR versions (this would explain why 7.x was updated after 9.x). The LTSB version (like all other 3rd Party LTSB / LTSR software) is for Customers that want to run a single version for a prolonged period. This is (supposed) to offer a more stable version that requires only security and / or critical updates and typically this branch will not receive any "feature" updates over its supported lifetime. This gives consistency, which is (supposed) to make the environment easier to manage, however, this doesn't account for bugs introduced by 3rd Party products in the LTSR stack (Hypervisor and VDI components). Currently, the only LTSB variant is 8.x and it's EOL is April 2022. The CR version (like all other 3rd Party CR software) is for Customers who want to run the latest features and functionality in their environments and the support lifetime for each branch is shorter than that of LTSB. The existing CR versions are 9.x which will become EOL on June 2020 and 10.x which will become EOL on December 2020. After which to maintain Support, you will be required to move to a supported version. vGPU features and functionality apply to more than just what's happening inside the VM. They apply to the rest of the environment as well. Multi vGPU and vGPU Live Migration to mention just two of them. If newer features and functionality are released throughout the lifecycle of an LTSB release, they will typically be available in the next supported branch, not the existing one. If a Customer keeps their entire environment up to date, then CR is the logical choice. This includes running the latest Hypervisor, VDI platform and Applications. CR is the version I always recommend (it has more than long enough support terms (typically one year)). Despite the claim of LTSB being easier to work with due to longer support, I'm yet to find that the case and personally I don't recommend it and will never implement a stack built around it. LTSB sounds great on the surface, but in reality, vGPU and other component features are being developed and released so quickly, that being stuck on an older release soon brings problems into the environment. For [u]example[/u], a day one release of LTSB is great because at some point in its release cycle it will be the latest release out of all three branches, but two years in to the platform, it's now three versions behind the CR, and the platform has very limited feature parity to current versions. Again, that may sound ok on the surface, but look at the feature differences between the current CR and LTSB .... I mention all of this because you've listed four vGPU versions in your post, including CR and LTSB versions. It's important to understand [b][u]why[/u][/b] you're running a specific vGPU version, and the implications of doing so. As mentioned, the 8.x branch is LTSB and the 9.x and 10.x are CR. Whatever happens to 8.x, both CR versions will always be more up to date with more features and functionality. The only changes to the 8.x branch will (or certainly should) be security and bug fixes (no features). Whereas 9.x and 10.x will receive security, bug fix and feature updates. Regarding the way they're displayed on the website, they're listed by Release Date (most recent at the top). The Versions are self explanatory. If you're currently running 9.x then you're running CR. You want to go to 10.x, so remove the 9.x .vib and install the 10.x .vib. Then upgrade your VMs with the appropriate driver (442.06 assuming you go for 10.1) included in the package. Regards MG
Hi

I could answer this with a one line response, but it's better to explain ...

NVIDIA maintain and support multiple driver branches. Therefore, different driver branches will have updated releases at different times. The drivers come in two versions: "Long-Term Support Branch" (LTSB, sometimes referred to as LTSR (R=Release) same thing, different acronym), and the other is what's known as "Current Release" (CR). NVIDIA will typically support three different branches concurrently, one LTSB and two CR versions (this would explain why 7.x was updated after 9.x).

The LTSB version (like all other 3rd Party LTSB / LTSR software) is for Customers that want to run a single version for a prolonged period. This is (supposed) to offer a more stable version that requires only security and / or critical updates and typically this branch will not receive any "feature" updates over its supported lifetime. This gives consistency, which is (supposed) to make the environment easier to manage, however, this doesn't account for bugs introduced by 3rd Party products in the LTSR stack (Hypervisor and VDI components). Currently, the only LTSB variant is 8.x and it's EOL is April 2022.

The CR version (like all other 3rd Party CR software) is for Customers who want to run the latest features and functionality in their environments and the support lifetime for each branch is shorter than that of LTSB. The existing CR versions are 9.x which will become EOL on June 2020 and 10.x which will become EOL on December 2020. After which to maintain Support, you will be required to move to a supported version.

vGPU features and functionality apply to more than just what's happening inside the VM. They apply to the rest of the environment as well. Multi vGPU and vGPU Live Migration to mention just two of them. If newer features and functionality are released throughout the lifecycle of an LTSB release, they will typically be available in the next supported branch, not the existing one.

If a Customer keeps their entire environment up to date, then CR is the logical choice. This includes running the latest Hypervisor, VDI platform and Applications. CR is the version I always recommend (it has more than long enough support terms (typically one year)). Despite the claim of LTSB being easier to work with due to longer support, I'm yet to find that the case and personally I don't recommend it and will never implement a stack built around it. LTSB sounds great on the surface, but in reality, vGPU and other component features are being developed and released so quickly, that being stuck on an older release soon brings problems into the environment. For example, a day one release of LTSB is great because at some point in its release cycle it will be the latest release out of all three branches, but two years in to the platform, it's now three versions behind the CR, and the platform has very limited feature parity to current versions. Again, that may sound ok on the surface, but look at the feature differences between the current CR and LTSB ....

I mention all of this because you've listed four vGPU versions in your post, including CR and LTSB versions. It's important to understand why you're running a specific vGPU version, and the implications of doing so.

As mentioned, the 8.x branch is LTSB and the 9.x and 10.x are CR. Whatever happens to 8.x, both CR versions will always be more up to date with more features and functionality. The only changes to the 8.x branch will (or certainly should) be security and bug fixes (no features). Whereas 9.x and 10.x will receive security, bug fix and feature updates.

Regarding the way they're displayed on the website, they're listed by Release Date (most recent at the top). The Versions are self explanatory. If you're currently running 9.x then you're running CR. You want to go to 10.x, so remove the 9.x .vib and install the 10.x .vib. Then upgrade your VMs with the appropriate driver (442.06 assuming you go for 10.1) included in the package.

Regards

MG

#2
Posted 02/29/2020 11:53 AM   
Wow, thanks for the long answer. Nice explanation
Wow, thanks for the long answer. Nice explanation

#3
Posted 03/04/2020 10:54 AM   
Scroll To Top

Add Reply