Artificial Intelligence Computing Leadership from NVIDIA
RTX 4000 in Passthrough in vSphere 6.7
Hi! I am using the RTX 4000 in vSphere 6.7 and assigned the adapter to the VM as PCI device ( 4 devices ). I installed the NVIDIA drivers in Windows 2016 VM. But when I RDP into the system and click on the Display properties it's telling me I am using Generic Monitor ( that's fine ) and using a MS drivers. Under the Device Manager I have disabled the VMware SVGA 3D adapter and left the RTX 4000 enabled. I am not able to change the resolution and also not able to add the GPU option in Task Manager to view the GPU utilization. Please help!
Hi! I am using the RTX 4000 in vSphere 6.7 and assigned the adapter to the VM as PCI device ( 4 devices ). I installed the NVIDIA drivers in Windows 2016 VM. But when I RDP into the system and click on the Display properties it's telling me I am using Generic Monitor ( that's fine ) and using a MS drivers. Under the Device Manager I have disabled the VMware SVGA 3D adapter and left the RTX 4000 enabled. I am not able to change the resolution and also not able to add the GPU option in Task Manager to view the GPU utilization. Please help!

#1
Posted 05/03/2020 02:05 AM   
Hi When installing VMTools, you should have unselected the SVGA driver so it wasn't installed. You need to change your connection protocol to something other than RDP. HDX, Blast, PCoIP, TGX, VNC will allow you to use the GPU properly. Regarding resolution, if using RDP you set that before you connect, you don't change it while your session is open. If using one of the other protocols, you can simply "full screen" the window and the internal resolution will automatically resize to match that of your physical monitor. Or you can manually drag the window to a size you want and the resolution will automatically adjust to the size of the window. There's no need to manually set the resolution within the VM. Regards MG
Hi

When installing VMTools, you should have unselected the SVGA driver so it wasn't installed.

You need to change your connection protocol to something other than RDP. HDX, Blast, PCoIP, TGX, VNC will allow you to use the GPU properly.

Regarding resolution, if using RDP you set that before you connect, you don't change it while your session is open. If using one of the other protocols, you can simply "full screen" the window and the internal resolution will automatically resize to match that of your physical monitor. Or you can manually drag the window to a size you want and the resolution will automatically adjust to the size of the window. There's no need to manually set the resolution within the VM.

Regards

MG

#2
Posted 05/04/2020 07:36 AM   
Thanks for the reply! Is there any way I can see the GPU tab in Task Manager in Windows 2016. I searched and searched but not able to find an answer. Also, the NVIDIA Control Panel setting "Usage Mode" "Use for Graphics and compute needs" option is per user or can Administrator set this for all users in a Terminal Server (Remote Desktop Services)?
Thanks for the reply! Is there any way I can see the GPU tab in Task Manager in Windows 2016. I searched and searched but not able to find an answer. Also, the NVIDIA Control Panel setting "Usage Mode" "Use for Graphics and compute needs" option is per user or can Administrator set this for all users in a Terminal Server (Remote Desktop Services)?

#3
Posted 05/04/2020 06:41 PM   
Hi No, Windows 2016 is too old. Windows 2019 or Windows 10 have that feature. You can use this application if you wish to see GPU metrics: https://github.com/JeremyMain/GPUProfiler/releases I believe an Admin can set that mode in a RDSH when connected with an appropriate protocol. Regards MG
Hi

No, Windows 2016 is too old. Windows 2019 or Windows 10 have that feature.

You can use this application if you wish to see GPU metrics: https://github.com/JeremyMain/GPUProfiler/releases

I believe an Admin can set that mode in a RDSH when connected with an appropriate protocol.

Regards

MG

#4
Posted 05/05/2020 07:27 AM   
Scroll To Top

Add Reply