NVIDIA
NVIDIA Grid K2 session freeze
Hello We have an HP DL380 with a GRID K2 running with XenServer 7. Our XenDesktop environment is 7.12 (the VDI machines are using the 7.11 VDA). On this server we are running VDI machines with WIN7 SP1 and auto cad 2016. Clients are running receiver 4.5 and 4.6. We are using the 3.61.45.09 NVIDIA GRID (K2) driver for XenServer 7. Our Windows 7 VDI Systems are using the 3.62.56 Windows 7 NVIDIA Driver. Sometimes the session freezes with the blue (Windows 7) welcome screen, and then we have to reboot this VDI VM in XenCenter to fix this issue. Our [b]NON[/b] GRID VDI systems doesn't have this problem. [b]I did some research on related issues on the Citrix and NVIDA forums:[/b] [url]http://discussions.citrix.com/topic/363221-xendesktop-76-grid-session-freeze/[/url] [url]http://discussions.citrix.com/topic/362749-xd-76-on-xenserver-65-with-nvidia-grid-k2-session-freeze/[/url] [url]https://gridforums.nvidia.com/default/topic/426/xendesktop-7-6-grid-session-freeze/[/url] [url]https://support.citrix.com/article/CTX201616[/url] Our next steps are updating the NVIDIA Driver on XenServer and updating the NVIDIA GRID K2 Windows 7 drivers. And maybe applying Citrix ICAWS760WX64029 so the Hd3dProviders.dll wil get an update. Has someone have the same problems or ideas to troubleshoot this issue? The problem is that this occurs sporadically. Thank you and I greatly appreciate any help you could render.
Hello

We have an HP DL380 with a GRID K2 running with XenServer 7.
Our XenDesktop environment is 7.12 (the VDI machines are using the 7.11 VDA).
On this server we are running VDI machines with WIN7 SP1 and auto cad 2016.
Clients are running receiver 4.5 and 4.6.

We are using the 3.61.45.09 NVIDIA GRID (K2) driver for XenServer 7.
Our Windows 7 VDI Systems are using the 3.62.56 Windows 7 NVIDIA Driver.

Sometimes the session freezes with the blue (Windows 7) welcome screen, and then we have to reboot this VDI VM in XenCenter to fix this issue.
Our NON GRID VDI systems doesn't have this problem.

I did some research on related issues on the Citrix and NVIDA forums:
http://discussions.citrix.com/topic/363221-xendesktop-76-grid-session-freeze/
http://discussions.citrix.com/topic/362749-xd-76-on-xenserver-65-with-nvidia-grid-k2-session-freeze/
https://gridforums.nvidia.com/default/topic/426/xendesktop-7-6-grid-session-freeze/
https://support.citrix.com/article/CTX201616

Our next steps are updating the NVIDIA Driver on XenServer and updating the NVIDIA GRID K2 Windows 7 drivers.
And maybe applying Citrix ICAWS760WX64029 so the Hd3dProviders.dll wil get an update.

Has someone have the same problems or ideas to troubleshoot this issue?
The problem is that this occurs sporadically.

Thank you and I greatly appreciate any help you could render.

#1
Posted 02/08/2017 10:13 AM   
Hi, I'm having the same issue on a new VDI project (so fully up-to-date system). Having the freezes almost every time when starting directly in a Dual-Screen mode, so when connecting in a Window or Single Full-Screen mode it appears far less frequent. When connected via a Window- or Single Full-screen mode and then extending to Dual-Screen mode works for the rest of the session. Downgrading the VDA to 7.9 fixes the issue, for Single and Dual-Screen mode but this isn't a acceptable solution as I can't use NVENC etc. Since VDA 7.11 there has been a change in the Video-Memory reservation but even after changing the value it doesn't help (even not sure if you need to change this when working with a Nvidia card) https://support.citrix.com/article/CTX218217 I don't think installing Citrix patch ICAWS760WX64029 will help has as it appears to be included in the newer VDA's: https://gridforums.nvidia.com/default/topic/426/nvidia-grid-vgpu/xendesktop-7-6-grid-session-freeze/2/ Created a Citrix-support case for this but Support hasn't been able to help so far (after creating memory-dumps/network/CDF traces when the issue occurs). Customer is using XA VDA 7.12 with a vGPU attached too and there we don't have any issue. So maybe it's related to the HDX3DPRO?
Hi,
I'm having the same issue on a new VDI project (so fully up-to-date system).
Having the freezes almost every time when starting directly in a Dual-Screen mode, so when connecting in a Window or Single Full-Screen mode it appears far less frequent.
When connected via a Window- or Single Full-screen mode and then extending to Dual-Screen mode works for the rest of the session.
Downgrading the VDA to 7.9 fixes the issue, for Single and Dual-Screen mode but this isn't a acceptable solution as I can't use NVENC etc.
Since VDA 7.11 there has been a change in the Video-Memory reservation but even after changing the value it doesn't help (even not sure if you need to change this when working with a Nvidia card)
https://support.citrix.com/article/CTX218217

I don't think installing Citrix patch ICAWS760WX64029 will help has as it appears to be included in the newer VDA's: https://gridforums.nvidia.com/default/topic/426/nvidia-grid-vgpu/xendesktop-7-6-grid-session-freeze/2/

Created a Citrix-support case for this but Support hasn't been able to help so far (after creating memory-dumps/network/CDF traces when the issue occurs).

Customer is using XA VDA 7.12 with a vGPU attached too and there we don't have any issue. So maybe it's related to the HDX3DPRO?

#2
Posted 02/08/2017 12:01 PM   
Hi cjacob thanks for your reply Citrix has announced 7.13 maybe this VDA has our wanted fix for this issue.
Hi cjacob thanks for your reply Citrix has announced 7.13 maybe this VDA has our wanted fix for this issue.

#3
Posted 02/08/2017 01:31 PM   
Scroll To Top

Add Reply