NVIDIA
Windows 2016 (Hyper-V) DDA /w GRID K520 for Win10VM
Hi all, So I've got a new Dell T630 which I am using at home for learning, I wanted to get into understanding how DDA worked particularly with Hyper-V 2016. The purchase leads me to buy workstation AMD FirePro graphics card, which worked perfectly in the machine until I went to use DDA to Windows 10 VM and found out that "consumer" cards cannot have the drivers install correctly unless it's a "GRID" family of GPU. So, I found a great price on a K520 and installed it into the Dell T630, passed one of the GPU's into Windows 10 VM and installed the drivers and everything is cool. However, this is where I am simply not sure that I made the right choice in a card. According to the website, this is a card used for Grid Gaming, so I thought it would be a good choice to play around and learn. However, although the drivers install fine, none of the NVIDIA control panel works over RDP nor does it work directly on the host itself. For the fun of it, I installed World of Warcraft on the VM to try it out, and it was not a beautiful experience, further, I tried out like the HTML5 Ferrari which works wonderfully on my Titan X, but via RDP it seems blah. The VM has 16 vCPU's attached and 24gb of ram, the storage runs on RAID 10 using NVME class storage while using bonded LCAP (correctly configured) 10GBEx2 connections to my desktop, so bandwidth isn't an issue. Did I make a mistake as far as getting this K520 over another type of card? I didn't have any solid goals for this minus just playing around with it, I at least wanted to see the ability to play a decent game remotely, but I might have misunderstood the purpose of NVIDIA Grid? Thanks for your help!
Hi all,

So I've got a new Dell T630 which I am using at home for learning, I wanted to get into understanding how DDA worked particularly with Hyper-V 2016. The purchase leads me to buy workstation AMD FirePro graphics card, which worked perfectly in the machine until I went to use DDA to Windows 10 VM and found out that "consumer" cards cannot have the drivers install correctly unless it's a "GRID" family of GPU.

So, I found a great price on a K520 and installed it into the Dell T630, passed one of the GPU's into Windows 10 VM and installed the drivers and everything is cool.

However, this is where I am simply not sure that I made the right choice in a card. According to the website, this is a card used for Grid Gaming, so I thought it would be a good choice to play around and learn. However, although the drivers install fine, none of the NVIDIA control panel works over RDP nor does it work directly on the host itself.

For the fun of it, I installed World of Warcraft on the VM to try it out, and it was not a beautiful experience, further, I tried out like the HTML5 Ferrari which works wonderfully on my Titan X, but via RDP it seems blah.

The VM has 16 vCPU's attached and 24gb of ram, the storage runs on RAID 10 using NVME class storage while using bonded LCAP (correctly configured) 10GBEx2 connections to my desktop, so bandwidth isn't an issue.

Did I make a mistake as far as getting this K520 over another type of card? I didn't have any solid goals for this minus just playing around with it, I at least wanted to see the ability to play a decent game remotely, but I might have misunderstood the purpose of NVIDIA Grid?

Thanks for your help!

#1
Posted 04/27/2017 04:52 PM   
Hi, to summarize you're using DDA for using the K520 in Passthrough mode for the mentioned Windows 10 VM. That should work easily. Did you use a tool like GPUprofiler to check if GPU acceleration is working? Which driver did you test? Regards Simon
Hi,

to summarize you're using DDA for using the K520 in Passthrough mode for the mentioned Windows 10 VM.
That should work easily. Did you use a tool like GPUprofiler to check if GPU acceleration is working?
Which driver did you test?

Regards

Simon

#2
Posted 04/28/2017 09:13 AM   
[quote="sschaber"]Hi, to summarize you're using DDA for using the K520 in Passthrough mode for the mentioned Windows 10 VM. That should work easily. Did you use a tool like GPUprofiler to check if GPU acceleration is working? Which driver did you test? Regards Simon[/quote] Simon, Thanks for your response. I installed on the host the same version as the VM: https://www.screencast.com/t/j4qnqLSkZxZQ https://www.screencast.com/t/aaglGlEB3T I think this is the GPUProfiler you are talking about: https://www.screencast.com/t/d6HZrE8wvSO7 https://www.screencast.com/t/30E5p3Uq https://www.screencast.com/t/WH9Xh6NMO It seems the video card is extremely underpowered or I've got something setup wrong? You would think if the whole point is to have a VM with a dedicated GPU, that one would be able to change graphics settings via RDP otherwise, what's the point of having it?
sschaber said:Hi,

to summarize you're using DDA for using the K520 in Passthrough mode for the mentioned Windows 10 VM.
That should work easily. Did you use a tool like GPUprofiler to check if GPU acceleration is working?
Which driver did you test?

Regards

Simon


Simon,

Thanks for your response.

I installed on the host the same version as the VM:

https://www.screencast.com/t/j4qnqLSkZxZQ
https://www.screencast.com/t/aaglGlEB3T

I think this is the GPUProfiler you are talking about:

https://www.screencast.com/t/d6HZrE8wvSO7

https://www.screencast.com/t/30E5p3Uq

https://www.screencast.com/t/WH9Xh6NMO

It seems the video card is extremely underpowered or I've got something setup wrong? You would think if the whole point is to have a VM with a dedicated GPU, that one would be able to change graphics settings via RDP otherwise, what's the point of having it?

#3
Posted 04/28/2017 01:36 PM   
Hi, OK it seems everything is working as expected. NV Control Panel is not working in RDP session, this is by design. This will change in an upcoming driver release. The K520 contains two GK104 (Kepler K5000) chips so it shouldn't be that bad. Most customers run Citrix XenDesktop or VMWare Horizon for good reason instead of native RDP :) So I would take the remoting protocol into consideration. Regards Simon
Hi,

OK it seems everything is working as expected. NV Control Panel is not working in RDP session, this is by design. This will change in an upcoming driver release. The K520 contains two GK104 (Kepler K5000) chips so it shouldn't be that bad. Most customers run Citrix XenDesktop or VMWare Horizon for good reason instead of native RDP :)
So I would take the remoting protocol into consideration.


Regards

Simon

#4
Posted 04/28/2017 04:29 PM   
Scroll To Top

Add Reply