Dell 730 + M10 + Windows 2012R2 (GUI) : GPUs not recognized by HyperV
Hi all, I am having some issues getting our Windows 2012R2 Hyper-V Host to recognize the GPUs installed on the server. In Hyper-V Manager Settings, under Physical GPUs, the option to select GPUs is greyed out and the message here says that “None of the GPUs on this computer support RemoteFx” … which is what I would like to Enable. My configuration is as following: Dell R730 Tesla M10 Windows 2012 R2 (with GUI, not Core) installed Baremetal Hyper-V Role installed with Remote Desktop Services (ie:Remote Desktop Virtualization Host component) I have tried the 385.08 Tesla display drivers. Also tried other the display drivers provided by Dell (377.29) The card is recognized correctly by W2012R2 as Tesla M40 (as indicated by Device Manager). In Device Manager (under Display Adapters), I also see “Microsoft Basic Display Adapter” which I’m assuming is not a problem. In the NVidia Control Panel, I don’t see an option for Licensing … I’m assuming because only GRID vGPUs require licensing, not the Tesla GPU? In the R730 BIOS, the following is configured: i) Embedded Video Controller is Enabled ii) Memory Mapped I/O above 4GB is Enabled (If I disable it, I get an error on Boot saying “Unable to allocate MMIO resources for one of more PCIe devices because of insufficient MMIO memory. iii) Virtualization Technology is Enabled iv) System Profile is set to Performance v) Boot Mode is set to UEFI Also, I tried both Windows 2016 (Full GUI) and same problem. I would really appreciate any help with this? I would love to have RemoteFX working for my Hyper-V environment. Thanks all!
Hi all,

I am having some issues getting our Windows 2012R2 Hyper-V Host to recognize the GPUs installed on the server. In Hyper-V Manager Settings, under Physical GPUs, the option to select GPUs is greyed out and the message here says that “None of the GPUs on this computer support RemoteFx” … which is what I would like to Enable. My configuration is as following:

Dell R730
Tesla M10
Windows 2012 R2 (with GUI, not Core) installed Baremetal
Hyper-V Role installed with Remote Desktop Services (ie:Remote Desktop Virtualization Host component)

I have tried the 385.08 Tesla display drivers. Also tried other the display drivers provided by Dell (377.29)

The card is recognized correctly by W2012R2 as Tesla M40 (as indicated by Device Manager). In Device Manager (under Display Adapters), I also see “Microsoft Basic Display Adapter” which I’m assuming is not a problem.

In the NVidia Control Panel, I don’t see an option for Licensing … I’m assuming because only GRID vGPUs require licensing, not the Tesla GPU?

In the R730 BIOS, the following is configured:
i) Embedded Video Controller is Enabled
ii) Memory Mapped I/O above 4GB is Enabled (If I disable it, I get an error on Boot saying “Unable to allocate MMIO resources for one of more PCIe devices because of insufficient MMIO memory.
iii) Virtualization Technology is Enabled
iv) System Profile is set to Performance
v) Boot Mode is set to UEFI

Also, I tried both Windows 2016 (Full GUI) and same problem.

I would really appreciate any help with this? I would love to have RemoteFX working for my Hyper-V environment.

Thanks all!

#1
Posted 08/03/2017 02:47 PM   
Hi, no matter if you use vGPU or RemoteFX (as you tried) you need a valid driver for GRID and GRID licenses (vPC for every VM running RemoteFX). You won't be able to run the drivers you tried because they don't support Tesla M10. Please create an account for the GRID portal to download the neccessary driver package: http://www.nvidia.com/content/token-link/index.html Regards Simon
Hi,
no matter if you use vGPU or RemoteFX (as you tried) you need a valid driver for GRID and GRID licenses (vPC for every VM running RemoteFX).
You won't be able to run the drivers you tried because they don't support Tesla M10.
Please create an account for the GRID portal to download the neccessary driver package:
http://www.nvidia.com/content/token-link/index.html

Regards

Simon

#2
Posted 08/03/2017 08:09 PM   
Scroll To Top