NVIDIA
Amazon EC2 GPU instance - OpenGL apps over RDP
Hi, I’m currently trying to get a GPU-accelerated Amazon EC2 instance (g2.2xlarge with NVIDIA GRID K520 on Windows Server 2016) to work properly over RDP. The main problem seems to be that applications which are using OpenGL won’t work (out-of-the-box) with RDP. In about 90% of all internet forums people state that one should consider using another Remote Desktop Protocoll. Likewise AWS does: [i]… When using Remote Desktop, GPUs that use the WDDM driver model are replaced with a non-accelerated Remote Desktop display driver. To access your GPU hardware, you must use a different remote access tool, such as VNC … http://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/accelerated-computing-instances.html[/i] However I’ve found out that this is not a technical limitation. It must be a configuration issue because of two reasons: 1. There is a workaround to get an OpenGL application running over RDP. You simply need to logon a session and start the application prior to connecting with RDP. This can be achieved with the help of Teamviewer (in multi user mode) as well as with Sysinternals Autologon and your desired GPU app in the autostart list. You can find a proof for that here https://www2.pic-upload.de/img/33786638/EC2-GPUoverRDP.png 2. My private cloud instance consisting of vSphere 6.5 VMs (with Grid cards) shows absolutely no problems when working with OpenGL apps over RDP. Interestingly the group policy settings that have made the breakthrough in the forum topic 1175 are completely untouched in these VMs. Sadly I cannot track all the configuration steps back that have been made on these VMs. Furthermore I cannot exclude that background settings (like registry keys) related to these GPOs haven’t been set by any other application. Ironically Google Chrome shows GPU activity with the "WebGL Water" test by Evan Wallace. But Furmark and Unigine Heaven in OpenGL-mode fail. Hope anyone can help here. Thanks, Robert
Hi,

I’m currently trying to get a GPU-accelerated Amazon EC2 instance (g2.2xlarge with NVIDIA GRID K520 on Windows Server 2016) to work properly over RDP. The main problem seems to be that applications which are using OpenGL won’t work (out-of-the-box) with RDP. In about 90% of all internet forums people state that one should consider using another Remote Desktop Protocoll.

Likewise AWS does:
… When using Remote Desktop, GPUs that use the WDDM driver model are replaced with a non-accelerated Remote Desktop display driver. To access your GPU hardware, you must use a different remote access tool, such as VNC …
http://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/accelerated-computing-instances.html


However I’ve found out that this is not a technical limitation. It must be a configuration issue because of two reasons:

1. There is a workaround to get an OpenGL application running over RDP. You simply need to logon a session and start the application prior to connecting with RDP. This can be achieved with the help of Teamviewer (in multi user mode) as well as with Sysinternals Autologon and your desired GPU app in the autostart list. You can find a proof for that here https://www2.pic-upload.de/img/33786638/EC2-GPUoverRDP.png


2. My private cloud instance consisting of vSphere 6.5 VMs (with Grid cards) shows absolutely no problems when working with OpenGL apps over RDP. Interestingly the group policy settings that have made the breakthrough in the forum topic 1175 are completely untouched in these VMs. Sadly I cannot track all the configuration steps back that have been made on these VMs. Furthermore I cannot exclude that background settings (like registry keys) related to these GPOs haven’t been set by any other application.


Ironically Google Chrome shows GPU activity with the "WebGL Water" test by Evan Wallace. But Furmark and Unigine Heaven in OpenGL-mode fail.


Hope anyone can help here.

Thanks,
Robert

#1
Posted 09/05/2017 09:18 AM   
Scroll To Top

Add Reply