NVIDIA
Compute M. Prohibited in Tesla vGRID M60-2Q
Hi ! i'm implementing a NVIDIA GRID vGPU virtualizating a Tesla M60 (in mode M60-2Q) to run a mathematical sofware utilizating the GPU to compute. I've noticed when i run nvidia-smi that "Compute M." is in "Prohibited". However, if i try to change it to Default or EXCLUSIVE PROCESS, i just cant! it saids that de change is made, but it is't. Could it be the problem the configuration of the virtual machine in M60-2Q? C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi Thu Sep 07 15:32:55 2017 +-----------------------------------------------------------------------------+ | NVIDIA-SMI 370.12 Driver Version: 370.12 | |-------------------------------+----------------------+----------------------+ | GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC | | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. | |===============================+======================+======================| | 0 GRID M60-2Q WDDM | 0000:02:04.0 On | N/A | | N/A N/A P0 N/A / N/A | 371MiB / 2048MiB | 1% Prohibited | +-------------------------------+----------------------+----------------------+ +-----------------------------------------------------------------------------+ | Processes: GPU Memory | | GPU PID Type Process name Usage | |=============================================================================| | 0 184 C+G Insufficient Permissions N/A | +-----------------------------------------------------------------------------+ C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi -c 1 Warning: Exclusive_Thread was deprecated! Setting Exclusive_Process instead. Unable to set compute mode for GPU 0000:02:04.0: WDDM devices may only run in D FAULT compute mode Treating as warning and moving on. All done. C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi -c 0 Set compute mode to DEFAULT for GPU 0000:02:04.0. All done. C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi Thu Sep 07 15:40:46 2017 +-----------------------------------------------------------------------------+ | NVIDIA-SMI 370.12 Driver Version: 370.12 | |-------------------------------+----------------------+----------------------+ | GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC | | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. | |===============================+======================+======================| | 0 GRID M60-2Q WDDM | 0000:02:04.0 On | N/A | | N/A N/A P0 N/A / N/A | 371MiB / 2048MiB | 2% Prohibited | +-------------------------------+----------------------+----------------------+ +-----------------------------------------------------------------------------+ | Processes: GPU Memory | | GPU PID Type Process name Usage | |=============================================================================| | 0 184 C+G Insufficient Permissions N/A | +-----------------------------------------------------------------------------+
Hi ! i'm implementing a NVIDIA GRID vGPU virtualizating a Tesla M60 (in mode M60-2Q) to run a mathematical sofware utilizating the GPU to compute. I've noticed when i run nvidia-smi that "Compute M." is in "Prohibited". However, if i try to change it to Default or EXCLUSIVE PROCESS, i just cant! it saids that de change is made, but it is't. Could it be the problem the configuration of the virtual machine in M60-2Q?

C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi
Thu Sep 07 15:32:55 2017
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 370.12 Driver Version: 370.12 |
|-------------------------------+----------------------+----------------------+
| GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GRID M60-2Q WDDM | 0000:02:04.0 On | N/A |
| N/A N/A P0 N/A / N/A | 371MiB / 2048MiB | 1% Prohibited |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 184 C+G Insufficient Permissions N/A |
+-----------------------------------------------------------------------------+
C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi -c 1
Warning: Exclusive_Thread was deprecated! Setting Exclusive_Process instead.
Unable to set compute mode for GPU 0000:02:04.0: WDDM devices may only run in D
FAULT compute mode
Treating as warning and moving on.
All done.

C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi -c 0
Set compute mode to DEFAULT for GPU 0000:02:04.0.
All done.

C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi
Thu Sep 07 15:40:46 2017
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 370.12 Driver Version: 370.12 |
|-------------------------------+----------------------+----------------------+
| GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GRID M60-2Q WDDM | 0000:02:04.0 On | N/A |
| N/A N/A P0 N/A / N/A | 371MiB / 2048MiB | 2% Prohibited |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 184 C+G Insufficient Permissions N/A |
+-----------------------------------------------------------------------------+

#1
Posted 09/07/2017 06:44 PM   
[url]https://docs.nvidia.com/grid/latest/grid-vgpu-user-guide/index.html#features-grid-vgpu[/url]: [code]CUDA and OpenCL are supported on these virtual GPUs: The 8Q vGPU type on Tesla M6, Tesla M10, and Tesla M60 GPUs. All Q-series vGPU types on the following GPUs: Tesla P4 Tesla P6 Tesla P40 Tesla P100 [/code] [i]My opinion: Or you can try to hack it if you known how to modify digitally signed parameters [url]https://gridforums.nvidia.com/default/topic/258/nvidia-grid-vgpu/documentation-for-vgpu-configs/post/665/#665[/url][/i]
https://docs.nvidia.com/grid/latest/grid-vgpu-user-guide/index.html#features-grid-vgpu:

CUDA and OpenCL are supported on these virtual GPUs:
The 8Q vGPU type on Tesla M6, Tesla M10, and Tesla M60 GPUs.
All Q-series vGPU types on the following GPUs:
Tesla P4
Tesla P6
Tesla P40
Tesla P100


My opinion: Or you can try to hack it if you known how to modify digitally signed parameters https://gridforums.nvidia.com/default/topic/258/nvidia-grid-vgpu/documentation-for-vgpu-configs/post/665/#665

#2
Posted 09/07/2017 07:06 PM   
mcerveny is correct, CUDA is only available with 8Q or Passthrough when using Maxwell GPUs. Regards
mcerveny is correct, CUDA is only available with 8Q or Passthrough when using Maxwell GPUs.

Regards

#3
Posted 09/08/2017 07:39 AM   
Thanks you both for the quick answer ! unfortunately i don't have the ability to hack it, and a mistake would be critical in my case, but thanks again !
Thanks you both for the quick answer ! unfortunately i don't have the ability to hack it, and a mistake would be critical in my case, but thanks again !

#4
Posted 09/08/2017 12:19 PM   
Scroll To Top

Add Reply