NVIDIA
vGPU Profile Selection for virtual machine not populating
Hello, i have an instance where when i run through the installation as described in the grid deployment guide ican add the pci device to the vm but i do not get the profiles box to populate it stays blank and i cannot use the gpu in more than one VM as a result. Anyone seen this? NVidia-grid-vgpu-vsphere-2015-346.42-347.52 View agent 6.0.1
Hello,

i have an instance where when i run through the installation as described in the grid deployment guide ican add the pci device to the vm but i do not get the profiles box to populate it stays blank and i cannot use the gpu in more than one VM as a result. Anyone seen this?

NVidia-grid-vgpu-vsphere-2015-346.42-347.52



View agent 6.0.1

#1
Posted 04/29/2015 02:34 PM   
Can you go to the command line of the ESXi host and run esxcli software vib list | grep -i nvidia Then copy & paste the results back here. Check xorg is running and that you have the relevant licenses available (Horizon VIEW, vSphere for Desktops or vSphere Enterprise Plus) Also, you need to upgrade to Horizon VIEW 6.1 to be able to fully administer pools with vGPU desktops in.
Can you go to the command line of the ESXi host and run

esxcli software vib list | grep -i nvidia

Then copy & paste the results back here.

Check xorg is running and that you have the relevant licenses available (Horizon VIEW, vSphere for Desktops or vSphere Enterprise Plus)



Also, you need to upgrade to Horizon VIEW 6.1 to be able to fully administer pools with vGPU desktops in.

Jason Southern, Regional Lead for ProVis Sales - EMEA: NVIDIA Ltd.

#2
Posted 04/29/2015 03:37 PM   
its 6.1 now we just upgraded today. still nothing in the drop down.. output NVIDIA-VMware_ESXi_6.0_Host_Driver 346.42-1OEM.600.0.0.2159203 NVIDIA VMwareAccepted 2015-04-24 I am told this is the incorrect driver but it is the only one available on the NVIDIA downloads page when i search for drivers. see image for what i am seeing in the web client
its 6.1 now we just upgraded today. still nothing in the drop down..

output NVIDIA-VMware_ESXi_6.0_Host_Driver 346.42-1OEM.600.0.0.2159203 NVIDIA VMwareAccepted 2015-04-24

I am told this is the incorrect driver but it is the only one available on the NVIDIA downloads page when i search for drivers.

see image for what i am seeing in the web client
Attachments

gpu.png

#3
Posted 04/29/2015 07:24 PM   
That's the vSGA driver, which you'll need to remove. You need to download the vGPU package which includes the vGPU Manager .vib and the driver that goes into the Guest (they are a matched pair) The drivers are on the download site and have been there since 12 March 2015, you have to select NVIDIA GRID vGPU as the Product Series in the search criteria and not leave it as GRID series.
That's the vSGA driver, which you'll need to remove.

You need to download the vGPU package which includes the vGPU Manager .vib and the driver that goes into the Guest (they are a matched pair)

The drivers are on the download site and have been there since 12 March 2015, you have to select NVIDIA GRID vGPU as the Product Series in the search criteria and not leave it as GRID series.

Jason Southern, Regional Lead for ProVis Sales - EMEA: NVIDIA Ltd.

#4
Posted 04/30/2015 08:32 AM   
Not sure when the last time was you may have examined that file but the only vib in there is NVIDIA-vgx-VMware_ESXi_6.0_Host_Driver_346.42-1OEM.600.0.0.2159203.vib, and when we install it on a clean host we get this output..... output NVIDIA-VMware_ESXi_6.0_Host_Driver 346.42-1OEM.600.0.0.2159203 NVIDIA VMwareAccepted 2015-04-24
Not sure when the last time was you may have examined that file but the only vib in there is NVIDIA-vgx-VMware_ESXi_6.0_Host_Driver_346.42-1OEM.600.0.0.2159203.vib, and when we install it on a clean host we get this output.....

output NVIDIA-VMware_ESXi_6.0_Host_Driver 346.42-1OEM.600.0.0.2159203 NVIDIA VMwareAccepted 2015-04-24

#5
Posted 04/30/2015 06:37 PM   
turns out my customer got confused on the file bundle he was using. seems to have resolved the issue. thanks for the help.
turns out my customer got confused on the file bundle he was using. seems to have resolved the issue. thanks for the help.

#6
Posted 05/01/2015 12:26 PM   
[quote="jaminator45"]Not sure when the last time was you may have examined that file but the only vib in there is NVIDIA-vgx-VMware_ESXi_6.0_Host_Driver_346.42-1OEM.600.0.0.2159203.vib, and when we install it on a clean host we get this output..... output NVIDIA-VMware_ESXi_6.0_Host_Driver 346.42-1OEM.600.0.0.2159203 NVIDIA VMwareAccepted 2015-04-24[/quote] Take a look at this YouTube video https://youtu.be/r34NCQS7pek You'll see at around the 00:46 mark to correct output for the vGPU .vib If when you grep the list it doesn't start with NVIDIA-vgx-VMware (vgx denotes that it's vGPU) then it's the vSGA driver. NVIDIA-VMware_ESXi_6.0_Host_Driver....etc is the driver naming convention agreed with VMware for this package, so it will not vary. It's an easy mistake to make and one that we see all to often, even though the deployment guide is very explicit about which drivers to download.
jaminator45 said:Not sure when the last time was you may have examined that file but the only vib in there is NVIDIA-vgx-VMware_ESXi_6.0_Host_Driver_346.42-1OEM.600.0.0.2159203.vib, and when we install it on a clean host we get this output.....

output NVIDIA-VMware_ESXi_6.0_Host_Driver 346.42-1OEM.600.0.0.2159203 NVIDIA VMwareAccepted 2015-04-24


Take a look at this YouTube video


https://youtu.be/r34NCQS7pek


You'll see at around the 00:46 mark to correct output for the vGPU .vib


If when you grep the list it doesn't start with NVIDIA-vgx-VMware (vgx denotes that it's vGPU) then it's the vSGA driver.

NVIDIA-VMware_ESXi_6.0_Host_Driver....etc is the driver naming convention agreed with VMware for this package, so it will not vary.

It's an easy mistake to make and one that we see all to often, even though the deployment guide is very explicit about which drivers to download.

Jason Southern, Regional Lead for ProVis Sales - EMEA: NVIDIA Ltd.

#7
Posted 05/05/2015 04:21 PM   
Scroll To Top

Add Reply