NVIDIA
Civil3D Performance with K2 Cards
Hello All! I'm currently in the tail end of a POC for a client that has been going rather well up until we added a particular bit of software into the mix. We're running a Dell 720 with 2x K2 cards along with ESXi 6.0 and XenDesktop/XenApp 7.6. Our machines are Windows 7 x64 along with 8-16GB of RAM and 8vCPU's. We have also tried running this software with the GRID K260q and K220q profiles with little difference in performance. Basically with all of the software we have tested, save for one in particular, the POC has gone rather well. However, when we added AutoDesk Civil3D into the mix, the performance of that application has halted our progress. The symptoms are as follows: -Poor "orbit/rotation" resulting in the model "degrading/simplifying" into a basic block model-Long delays between commands (orbit, pan, redraw, etc) -Sluggishness when operating in the UI I have gone through and performed some of the recomended "performance optimizations" that I have found about the internet. However, I still feel that the performance falls WAY short of what we're able to do with some of the other software. I'm even able to run fully graphically intense applications (games, facial renders, etc) with ease. I understand that the mathmatical application is diferent, but this is downright awful in some instances. I'm reaching out through different aveunes to see what assistance in troubleshooting this. I'll be attempting to work with AutoDesk on the issue as well. I'm hoping that others have come across this and may have some insight into the issue. Thank you! -Adam
Hello All!

I'm currently in the tail end of a POC for a client that has been going rather well up until we added a particular bit of software into the mix.

We're running a Dell 720 with 2x K2 cards along with ESXi 6.0 and XenDesktop/XenApp 7.6. Our machines are Windows 7 x64 along with 8-16GB of RAM and 8vCPU's. We have also tried running this software with the GRID K260q and K220q profiles with little difference in performance.

Basically with all of the software we have tested, save for one in particular, the POC has gone rather well. However, when we added AutoDesk Civil3D into the mix, the performance of that application has halted our progress.

The symptoms are as follows:
-Poor "orbit/rotation" resulting in the model "degrading/simplifying" into a basic block model-Long delays between commands (orbit, pan, redraw, etc)
-Sluggishness when operating in the UI

I have gone through and performed some of the recomended "performance optimizations" that I have found about the internet. However, I still feel that the performance falls WAY short of what we're able to do with some of the other software. I'm even able to run fully graphically intense applications (games, facial renders, etc) with ease. I understand that the mathmatical application is diferent, but this is downright awful in some instances.

I'm reaching out through different aveunes to see what assistance in troubleshooting this. I'll be attempting to work with AutoDesk on the issue as well. I'm hoping that others have come across this and may have some insight into the issue.

Thank you!

-Adam

#1
Posted 09/08/2015 02:14 PM   
Is hardware acceleration turned on in Civil 3D applications? You may need to switch on hardware acceleration manually if the applications haven't detected the card. AutoCAD 2015 is certified for the 260Q profile, http://usa.autodesk.com/adsk/servlet/syscert/card?siteID=123112&catID=18254205&id=18844534&product=106&os=8192&hw=343 as is Revit http://usa.autodesk.com/adsk/servlet/syscert/card?siteID=123112&catID=18254205&id=18844534&product=115&os=8192&hw=343 There may be other issues at play, such as needing ot fine tune the HDX protocol, http://discussions.citrix.com/topic/357800-template-exchange-studio-templates-%E2%80%93-help-needed-out-of-the-box-configuration-for-xendesktop-and-xenapp/ You don't descrie the network conditions you're testin in, but often UI "sluggishness" is down to latency being exagerrated when combined with VM rendered cursors. You can adjust the mouse timer value on the client side to compensate.
Is hardware acceleration turned on in Civil 3D applications?

You may need to switch on hardware acceleration manually if the applications haven't detected the card.

AutoCAD 2015 is certified for the 260Q profile,


http://usa.autodesk.com/adsk/servlet/syscert/card?siteID=123112&catID=18254205&id=18844534&product=106&os=8192&hw=343


as is Revit


http://usa.autodesk.com/adsk/servlet/syscert/card?siteID=123112&catID=18254205&id=18844534&product=115&os=8192&hw=343


There may be other issues at play, such as needing ot fine tune the HDX protocol,


http://discussions.citrix.com/topic/357800-template-exchange-studio-templates-%E2%80%93-help-needed-out-of-the-box-configuration-for-xendesktop-and-xenapp/


You don't descrie the network conditions you're testin in, but often UI "sluggishness" is down to latency being exagerrated when combined with VM rendered cursors. You can adjust the mouse timer value on the client side to compensate.

Jason Southern, Regional Lead for ProVis Sales - EMEA: NVIDIA Ltd.

#2
Posted 09/08/2015 02:37 PM   
Jason, Thank you for your prompt reply. Thankfully, Civil3D recognizes the GPU (profile) without issue and is listed on the Hardware Acceleration page and listed as "On". I have spent a large portion of time with the HDX protocols in an attempt to smooth things out. While other applications such as Tekla Structures/BIMsight and Revit work great, Civil3D acts like it is running short on resources. We are running this from a data center to remote work stations. Again, other applications are able to run smooth without issue, however, Civil3D seems to be bogged down. I'm working on getting a case open with AutoDesk and hopefully I will have more information to report back with.
Jason,

Thank you for your prompt reply.

Thankfully, Civil3D recognizes the GPU (profile) without issue and is listed on the Hardware Acceleration page and listed as "On".

I have spent a large portion of time with the HDX protocols in an attempt to smooth things out. While other applications such as Tekla Structures/BIMsight and Revit work great, Civil3D acts like it is running short on resources.

We are running this from a data center to remote work stations. Again, other applications are able to run smooth without issue, however, Civil3D seems to be bogged down.

I'm working on getting a case open with AutoDesk and hopefully I will have more information to report back with.

#3
Posted 09/08/2015 03:58 PM   
Good to know it's recognising the profile. Are you running out of CPU resources? I've seen the CPU clock speed have a dramatic effect on the AutoDesk products, but as you're running Tekla Structures which is also a little CPU hungry I"m surprised it's not performing well. I forgot to link these earlier, though they're written on VMware the configuration for VM's should cross to XenDesktop without issue. http://images.nvidia.com/content/pdf/grid/guides/NVIDIA-GRID%E2%84%A2-vGPU%E2%84%A2-APPLICATION-GUIDE-FOR-AUTODESK-AUTOCAD-2015-ON-VMWARE-HORIZON.pdf http://www.nvidia.com/content/grid/resources/vGPU_App%20Guide_Revit_1.1_FINAL.pdf
Good to know it's recognising the profile.

Are you running out of CPU resources? I've seen the CPU clock speed have a dramatic effect on the AutoDesk products, but as you're running Tekla Structures which is also a little CPU hungry I"m surprised it's not performing well.

I forgot to link these earlier, though they're written on VMware the configuration for VM's should cross to XenDesktop without issue.


http://images.nvidia.com/content/pdf/grid/guides/NVIDIA-GRID%E2%84%A2-vGPU%E2%84%A2-APPLICATION-GUIDE-FOR-AUTODESK-AUTOCAD-2015-ON-VMWARE-HORIZON.pdf


http://www.nvidia.com/content/grid/resources/vGPU_App%20Guide_Revit_1.1_FINAL.pdf

Jason Southern, Regional Lead for ProVis Sales - EMEA: NVIDIA Ltd.

#4
Posted 09/08/2015 04:04 PM   
Yes, Tekla Structures and Tekla BIMSight run great up until I import 5 tons worth of structural rebar into the model. However, to be fair, a physical work station running a K4000 suffers also. We're running Xenon E5 rated at 2.8GHz on the host. I've tested between 4 and 16 vCPU's on the VM's themselves. I don't believe that Civil3D is able to really take advantage of the multiple cores. When running 16 cores, it peaks out less than 25% usage of the available CPU in total. When running 8 cores, it still falls into that general ball park of usage. Thank you for posting the reference material also. I'll review and see if that can shed any light on the situation.
Yes, Tekla Structures and Tekla BIMSight run great up until I import 5 tons worth of structural rebar into the model. However, to be fair, a physical work station running a K4000 suffers also.

We're running Xenon E5 rated at 2.8GHz on the host. I've tested between 4 and 16 vCPU's on the VM's themselves. I don't believe that Civil3D is able to really take advantage of the multiple cores. When running 16 cores, it peaks out less than 25% usage of the available CPU in total. When running 8 cores, it still falls into that general ball park of usage.

Thank you for posting the reference material also. I'll review and see if that can shed any light on the situation.

#5
Posted 09/08/2015 06:29 PM   
So something that has helped prevent the model from degrading during rotation is the following command within Civil 3D: Toggle Adaptive Degradation At the Command prompt, enter -GRAPHICSCONFIG. Enter a (Adaptive Degradation) and select a mode. Set the Performance Level for Adaptive Degradation At the Command prompt, enter -GRAPHICSCONFIG. Enter a (Adaptive Degradation) and select ON mode. Enter a number of frames per second. This however, highlights the lack of fluidity when rotating a model. Currently still hunting performance optimizations or a solution to speeding up the delivered frame rates.
So something that has helped prevent the model from degrading during rotation is the following command within Civil 3D:


Toggle Adaptive Degradation

At the Command prompt, enter -GRAPHICSCONFIG.
Enter a (Adaptive Degradation) and select a mode.

Set the Performance Level for Adaptive Degradation

At the Command prompt, enter -GRAPHICSCONFIG.
Enter a (Adaptive Degradation) and select ON mode.
Enter a number of frames per second.

This however, highlights the lack of fluidity when rotating a model.

Currently still hunting performance optimizations or a solution to speeding up the delivered frame rates.

#6
Posted 09/09/2015 02:00 PM   
So I wanted to post some of my findings which have greatly improved performance over the last week or so. Civil3D will only utilize 1 core from a multi core CPU. When virtualized, this was causing an issue where it was attempting to use all available cores on the VM. This was causing a fairly significant performance hit. I was able to configure CPU affinity for the acad.exe process and assign it to only 1 core. This sped up performance. Also, configuring the mouse queue timer and setting it to 1 ms helped with mouse lag. The second thing to help with mouse lag was our latest update to the NetScaler. Surprisingly this was a fairly major improvement when moving the mouse in the drawing area. Lastly, testing other models from grabcad.com has allowed me to test other models that are hopefully cleaner and more efficient. Come to find out, one of the models that a client provided was even a slouch on our K4000 desktop. I have been testing against a desktop running an NVIDIA K4000 card. The performance is approaching being similar. Still not quite the same, but I am MUCH closer than when I initially started. Hopefully I can squeeze a little more blood out of this turnip and make it 100%.
So I wanted to post some of my findings which have greatly improved performance over the last week or so.

Civil3D will only utilize 1 core from a multi core CPU. When virtualized, this was causing an issue where it was attempting to use all available cores on the VM. This was causing a fairly significant performance hit. I was able to configure CPU affinity for the acad.exe process and assign it to only 1 core. This sped up performance.

Also, configuring the mouse queue timer and setting it to 1 ms helped with mouse lag.

The second thing to help with mouse lag was our latest update to the NetScaler. Surprisingly this was a fairly major improvement when moving the mouse in the drawing area.

Lastly, testing other models from grabcad.com has allowed me to test other models that are hopefully cleaner and more efficient. Come to find out, one of the models that a client provided was even a slouch on our K4000 desktop.

I have been testing against a desktop running an NVIDIA K4000 card. The performance is approaching being similar. Still not quite the same, but I am MUCH closer than when I initially started. Hopefully I can squeeze a little more blood out of this turnip and make it 100%.

#7
Posted 09/17/2015 02:08 PM   
Adam, we are looking into GPUs on Horizon View 6.x. Native non-GPU performance was acceptable on 2011 C3D but has been a bear on 2015. The main complaint is cursor lag, something I knew would be an issue and remains so. In the home office things are close to acceptable but outside (branch, homes) the biggest contributor to problems is latency, it just has to be low. Do you find Netscaler helps with the cursor lag all that much? The users are pretty noisy if everything isn't as good as their PC desktop experience. All the virtual folks need to work with Autodesk to get a handle on cursor lag, it is pervasive in notes I've read. Btw if you enter this command in AutoCAD's startup lisp routine, it will automatically set the process affinity to 1 core: (command "DUMPMEMALLOC" "A")
Adam, we are looking into GPUs on Horizon View 6.x. Native non-GPU performance was acceptable on 2011 C3D but has been a bear on 2015.

The main complaint is cursor lag, something I knew would be an issue and remains so. In the home office things are close to acceptable but outside (branch, homes) the biggest contributor to problems is latency, it just has to be low. Do you find Netscaler helps with the cursor lag all that much? The users are pretty noisy if everything isn't as good as their PC desktop experience. All the virtual folks need to work with Autodesk to get a handle on cursor lag, it is pervasive in notes I've read.

Btw if you enter this command in AutoCAD's startup lisp routine, it will automatically set the process affinity to 1 core:

(command "DUMPMEMALLOC" "A")

#8
Posted 09/21/2015 06:36 PM   
[quote="iiagdtr"]Adam, we are looking into GPUs on Horizon View 6.x. Native non-GPU performance was acceptable on 2011 C3D but has been a bear on 2015. The main complaint is cursor lag, something I knew would be an issue and remains so. In the home office things are close to acceptable but outside (branch, homes) the biggest contributor to problems is latency, it just has to be low. Do you find Netscaler helps with the cursor lag all that much? The users are pretty noisy if everything isn't as good as their PC desktop experience. All the virtual folks need to work with Autodesk to get a handle on cursor lag, it is pervasive in notes I've read. Btw if you enter this command in AutoCAD's startup lisp routine, it will automatically set the process affinity to 1 core: (command "DUMPMEMALLOC" "A")[/quote] iiagdtr I apologize for my slow reply. After our Netscaler update as well as the registry tweak to the mouse queue the mouse lag is minimal at this point. I still see it when I've got a major model loaded up, however, for typical use, it is minimal. Thank you for the command also. I had some windows command launch work around going, but this looks like it'll be much cleaner. I guess another thing I would like to throw out there is: How does one quantify what is a "big" model vs a "normal" or "small" model? Overall file size seems to have very little to do with it for the most part. I have a few files that are in the 25-30MB range that perform well, however, I've got a a file that is less than 1MB that performs like a stick in the mud.
iiagdtr said:Adam, we are looking into GPUs on Horizon View 6.x. Native non-GPU performance was acceptable on 2011 C3D but has been a bear on 2015.

The main complaint is cursor lag, something I knew would be an issue and remains so. In the home office things are close to acceptable but outside (branch, homes) the biggest contributor to problems is latency, it just has to be low. Do you find Netscaler helps with the cursor lag all that much? The users are pretty noisy if everything isn't as good as their PC desktop experience. All the virtual folks need to work with Autodesk to get a handle on cursor lag, it is pervasive in notes I've read.

Btw if you enter this command in AutoCAD's startup lisp routine, it will automatically set the process affinity to 1 core:

(command "DUMPMEMALLOC" "A")


iiagdtr

I apologize for my slow reply.

After our Netscaler update as well as the registry tweak to the mouse queue the mouse lag is minimal at this point. I still see it when I've got a major model loaded up, however, for typical use, it is minimal.

Thank you for the command also. I had some windows command launch work around going, but this looks like it'll be much cleaner.

I guess another thing I would like to throw out there is: How does one quantify what is a "big" model vs a "normal" or "small" model? Overall file size seems to have very little to do with it for the most part. I have a few files that are in the 25-30MB range that perform well, however, I've got a a file that is less than 1MB that performs like a stick in the mud.

#9
Posted 10/12/2015 02:32 PM   
Scroll To Top

Add Reply