NVIDIA
Necessary to disable "Above 4G Decoding" for View with vGPU?
Hi All, I am reading through the GRID deployment guide for View 6.2 at the following link: https://www.vmware.com/files/pdf/products/horizon/grid-vgpu-deployment-guide.pdf On page 17, it gives the BIOS recommendations for several server manufacturers. It advises to disable the "Above 4G Decoding" for SuperMicro. This was necessary for XenServer 6.2 where Dom0 was 32bit. In the 64bit Dom0 of XenServer 6.5, it is not necessary to disable this setting. The vmkernel is 64 bit so I want to know if it is really necessary to disable this setting? On our test SuperMicro, disabling this setting generates an "Insufficient PCI Resources Detected" warning. All the SuperMicro support articles advise to enable "Above 4G Decoding" to resolve this warning message. The BIOS is at the latest version and SuperMicro is straight from the factory and we've used this same model for GRID on XenServer 6.2 and 6.5 without issue. If you have experience with the "Above 4G Decoding" setting for vSphere 6 and View with vGPU, please advise. Thanks! Richard
Hi All,

I am reading through the GRID deployment guide for View 6.2 at the following link:


https://www.vmware.com/files/pdf/products/horizon/grid-vgpu-deployment-guide.pdf


On page 17, it gives the BIOS recommendations for several server manufacturers. It advises to disable the "Above 4G Decoding" for SuperMicro. This was necessary for XenServer 6.2 where Dom0 was 32bit. In the 64bit Dom0 of XenServer 6.5, it is not necessary to disable this setting. The vmkernel is 64 bit so I want to know if it is really necessary to disable this setting?

On our test SuperMicro, disabling this setting generates an "Insufficient PCI Resources Detected" warning. All the SuperMicro support articles advise to enable "Above 4G Decoding" to resolve this warning message. The BIOS is at the latest version and SuperMicro is straight from the factory and we've used this same model for GRID on XenServer 6.2 and 6.5 without issue.

If you have experience with the "Above 4G Decoding" setting for vSphere 6 and View with vGPU, please advise.

Thanks!

Richard

#1
Posted 09/17/2015 07:51 PM   
Hi Richard, What happened when you did leave it enabled? Did you discuss with SMicro?
Hi Richard,
What happened when you did leave it enabled? Did you discuss with SMicro?

#2
Posted 09/18/2015 08:52 PM   
I'm running into exactly the same issue. Did you go back and enable that setting? Do your GRID cards still work fine for vGPU?
I'm running into exactly the same issue. Did you go back and enable that setting? Do your GRID cards still work fine for vGPU?

#3
Posted 09/21/2015 07:38 PM   
Hi All, I have been pulled onto some other urgent issues but I'll post my results when I get back to this project. Cheers, Richard
Hi All,

I have been pulled onto some other urgent issues but I'll post my results when I get back to this project.

Cheers,

Richard

#4
Posted 10/01/2015 04:05 PM   
Any info you could provide would be great. I'm dead in the water at the moment. If this doesn't work with Supermicro for some reason I need to know so I can move on. Much appreciated.
Any info you could provide would be great. I'm dead in the water at the moment. If this doesn't work with Supermicro for some reason I need to know so I can move on. Much appreciated.

#5
Posted 10/02/2015 03:04 PM   
Found the issue: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2050443 MMIO above 4GB not supported. Supermicro has to find a way to allow the server to fully boot if "Above 4G Decoding" is changed to disabled.
Found the issue:


http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2050443


MMIO above 4GB not supported. Supermicro has to find a way to allow the server to fully boot if "Above 4G Decoding" is changed to disabled.

#6
Posted 10/02/2015 04:55 PM   
here is the answer from supermicro: http://www.supermicro.com/support/faqs/faq.cfm?faq=20016 vGPU requires above 4g decoding to be ENABLED, while vDGA requires it to be DISABLED
here is the answer from supermicro: http://www.supermicro.com/support/faqs/faq.cfm?faq=20016

vGPU requires above 4g decoding to be ENABLED, while vDGA requires it to be DISABLED

#7
Posted 05/21/2016 05:21 AM   
[quote="chune"]here is the answer from supermicro: http://www.supermicro.com/support/faqs/faq.cfm?faq=20016 vGPU requires above 4g decoding to be ENABLED, while vDGA requires it to be DISABLED [/quote] It is not complete answer to solve VMware well known bug. Follow: [url]https://gridforums.nvidia.com/default/topic/808/nvidia-grid-drivers/grid-3-0-successfully-installs-on-esxi-6-0-2-with-m60-gpu-but-fails-to-verify-via-nvidia-smi/[/url] Extracted to NVidia KB: [url]http://nvidia.custhelp.com/app/answers/detail/a_id/4119/[/url]
chune said:here is the answer from supermicro: http://www.supermicro.com/support/faqs/faq.cfm?faq=20016
vGPU requires above 4g decoding to be ENABLED, while vDGA requires it to be DISABLED

It is not complete answer to solve VMware well known bug.

Follow: https://gridforums.nvidia.com/default/topic/808/nvidia-grid-drivers/grid-3-0-successfully-installs-on-esxi-6-0-2-with-m60-gpu-but-fails-to-verify-via-nvidia-smi/
Extracted to NVidia KB: http://nvidia.custhelp.com/app/answers/detail/a_id/4119/

#8
Posted 05/21/2016 06:36 AM   
Scroll To Top

Add Reply