NVIDIA
Autodesk inventor 2015 3d GRID performance problem
Hi guys, I'm now on this forum and I'm writing because i've find a problem during a POC. On my dell server ( r730 + nvidia grid k2) i've configured esxi6+horizon view 6.2 with windows 7 64bit as deployed vms. I've installed autodesk inventor 2015 but i've noticed that is impossible to enable the video hardware acceleration. Every time that i launch inventor the software graphics "checkbox" (under application options/hardware) is enabled and if I remove the check next time I open the software is enabled again. I've tried to: 1-force the application to use nvidia card trought nvidia control panel 2-disable integrated vmware video card (but in this case dxdiag gives me an error) 3-modify inventor configuration's file as suggested in this forum http://www.arch-pub.com/Experience-getting-Inventor-to-run-in-Citrix-environment_10624911.html after the third point is possible to disable the checkbox but if I launch the integrated test it report that the video hardware in use is the vmware 3d vga instead of the nvidia grid. Any suggestions..???
Hi guys,
I'm now on this forum and I'm writing because i've find a problem during a POC.
On my dell server ( r730 + nvidia grid k2) i've configured esxi6+horizon view 6.2 with windows 7 64bit as deployed vms.
I've installed autodesk inventor 2015 but i've noticed that is impossible to enable the video hardware acceleration.
Every time that i launch inventor the software graphics "checkbox" (under application options/hardware) is enabled and if I remove the check next time I open the software is enabled again.
I've tried to:
1-force the application to use nvidia card trought nvidia control panel
2-disable integrated vmware video card (but in this case dxdiag gives me an error)
3-modify inventor configuration's file as suggested in this forum http://www.arch-pub.com/Experience-getting-Inventor-to-run-in-Citrix-environment_10624911.html


after the third point is possible to disable the checkbox but if I launch the integrated test it report that the video hardware in use is the vmware 3d vga instead of the nvidia grid.

Any suggestions..???

#1
Posted 02/01/2016 09:05 AM   
Have you seen this thread: https://gridforums.nvidia.com/default/topic/699/autodesk-are-picking-the-wrong-gpu-when-connectint-with-xendesktop/ there maybe others with Autodesk experience on it... The Citrix and VMware forums are also a good source of info: http://discussions.citrix.com/forum/523-gpu-technologies/ The hypervisors implementations are very similar so if it's application specific worth checking out both VMware and citrix. I'll ask our solutions team if they know of specific autodesk inventor gotchas too.
Have you seen this thread: https://gridforums.nvidia.com/default/topic/699/autodesk-are-picking-the-wrong-gpu-when-connectint-with-xendesktop/ there maybe others with Autodesk experience on it... The Citrix and VMware forums are also a good source of info: http://discussions.citrix.com/forum/523-gpu-technologies/ The hypervisors implementations are very similar so if it's application specific worth checking out both VMware and citrix. I'll ask our solutions team if they know of specific autodesk inventor gotchas too.

#2
Posted 02/01/2016 10:38 AM   
Thanks for the answer, I've tried to find more information on the links but I haven't found a solution. i've tries this suggests http://answers.microsoft.com/en-us/windows/forum/windows8_1-hardware/in-the-registry-appinitdlls-lists-the-same-dll/857afbe1-6b2b-40ff-b6e5-0a0ec01421a1?auth=1 with https://support.microsoft.com/en-us/kb/197571 but nothig change... :( a very strange think is that autodesk autocad 2015 work perfectly with 3d acceleration enable with grid card...
Thanks for the answer, I've tried to find more information on the links but I haven't found a solution.
i've tries this suggests


http://answers.microsoft.com/en-us/windows/forum/windows8_1-hardware/in-the-registry-appinitdlls-lists-the-same-dll/857afbe1-6b2b-40ff-b6e5-0a0ec01421a1?auth=1


with


https://support.microsoft.com/en-us/kb/197571


but nothig change... :(

a very strange think is that autodesk autocad 2015 work perfectly with 3d acceleration enable with grid card...

#3
Posted 02/04/2016 08:42 AM   
It does sound inventor specific, if you are sure other apps can use the GPU and the NVIDIA driver is in use. I've seen this running on the Citrix stack so perhaps asking on the VMware forums; I haven't had a lot of View experience (I joined NVIDIA this month from the vGPU projects at Citrix so couldn't/didn't work on/with View)
It does sound inventor specific, if you are sure other apps can use the GPU and the NVIDIA driver is in use.

I've seen this running on the Citrix stack so perhaps asking on the VMware forums; I haven't had a lot of View experience (I joined NVIDIA this month from the vGPU projects at Citrix so couldn't/didn't work on/with View)

#4
Posted 02/04/2016 10:45 AM   
Hi guys, running in nearly the same problem. ESX6, GRID K2, XenDesktop 7.9, Windows 7, Inventor 2015. Disbaled VMware Graphics from DeviceManager. Auto CAD uses Grid K240Q - in Inventor "Software Graphics" is always checked. Edited hardwarelibrarydm and changed all Citrix-Values to 50 - no effect. Any advice would be appreciated. Graphics Device Information: Renderer: SW Manufacturer: NVIDIA Chip Type: GRID K240Q DAC Type: Integrated RAMDAC Graphics HW Memory: 892 MB Display Mode: 1073741824 x 1073741824 (1073741824 bit) (1073741824 Hz) Graphics driver file: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um Driver file version: 10.18.13.5480 Driver Date: 17 February 2016 0:00:00 UTC (Coordinated Universal Time) Graphics driver log information: Failed to create a device from the adapter. DXDIAG shows no errors. Marco
Hi guys,

running in nearly the same problem.

ESX6, GRID K2, XenDesktop 7.9, Windows 7, Inventor 2015.
Disbaled VMware Graphics from DeviceManager.
Auto CAD uses Grid K240Q - in Inventor "Software Graphics" is always checked.

Edited hardwarelibrarydm and changed all Citrix-Values to 50 - no effect.

Any advice would be appreciated.

Graphics Device Information:

Renderer: SW
Manufacturer: NVIDIA
Chip Type: GRID K240Q
DAC Type: Integrated RAMDAC
Graphics HW Memory: 892 MB
Display Mode: 1073741824 x 1073741824 (1073741824 bit) (1073741824 Hz)

Graphics driver file: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver file version: 10.18.13.5480
Driver Date: 17 February 2016 0:00:00 UTC (Coordinated Universal Time)

Graphics driver log information:
Failed to create a device from the adapter.

DXDIAG shows no errors.

Marco

#5
Posted 07/02/2016 05:48 PM   
.. just updated to the lastest GRID dirvers (ESX Host and Win7 VM), no change. Graphics driver file: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um Driver file version: 10.18.13.6256 Driver Date: 10 May 2016 0:00:00 UTC (Coordinated Universal Time) Graphics driver log information: Failed to create a device from the adapter. Failed to create a device from the adapter. Failed to create a device from the adapter. Failed to create a device from the adapter. Failed to create a device from the adapter. Failed to create a device from the adapter.
.. just updated to the lastest GRID dirvers (ESX Host and Win7 VM), no change.

Graphics driver file: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver file version: 10.18.13.6256
Driver Date: 10 May 2016 0:00:00 UTC (Coordinated Universal Time)


Graphics driver log information:
Failed to create a device from the adapter.
Failed to create a device from the adapter.
Failed to create a device from the adapter.
Failed to create a device from the adapter.
Failed to create a device from the adapter.
Failed to create a device from the adapter.

#6
Posted 07/03/2016 11:05 AM   
Hi folks, Could you check the Inventor 2015 patch level. Autodesk has a known issue and issued a fix in SP2 so you need to upgrade for VMware from base to SP2 the fix is described as "Improved GPU performance for VMWare" in https://knowledge.autodesk.com/sites/default/files/file_downloads/INV19130_enu.htm It may also be worth seeing if on a base inventor whether disabling the vmware adapter inside Windows Device Manager works as that would give me a clue as to what might be happening. Many thanks, Rachel
Hi folks,

Could you check the Inventor 2015 patch level. Autodesk has a known issue and issued a fix in SP2 so you need to upgrade for VMware from base to SP2
the fix is described as "Improved GPU performance for VMWare" in https://knowledge.autodesk.com/sites/default/files/file_downloads/INV19130_enu.htm

It may also be worth seeing if on a base inventor whether disabling the vmware adapter inside Windows Device Manager works as that would give me a clue as to what might be happening.

Many thanks,
Rachel

#7
Posted 07/07/2016 09:36 AM   
Hi all, I can confirm Rachels solution. Installing Inventor SP2 fixed my Problem and Hardware Rendering was enabled. However I had to reinstall Inventor completely - just adding SP2 to my existing Installation did not work! Thanks again Rachel - somehow its hard this times to jump between Citrix, VMware, NVidia and Autodesk to get a solution. Hope this will improve in future ;)
Hi all,
I can confirm Rachels solution.
Installing Inventor SP2 fixed my Problem and Hardware Rendering was enabled.

However I had to reinstall Inventor completely - just adding SP2 to my existing Installation did not work!

Thanks again Rachel - somehow its hard this times to jump between Citrix, VMware, NVidia and Autodesk to get a solution. Hope this will improve in future ;)

#8
Posted 07/12/2016 06:50 AM   
Scroll To Top

Add Reply