NVIDIA
frame rate limiter feature
Hello. There is probably bug/feature in drivers 352.83/354.80 (on Grid K2). Frame rate limiter (enabled by default with frame_rate_limiter 1/frl_config 0x3C) limits at 70 FPS instead of expected 60 FPS. Tested with Heaven benchmark and windowed lowres @ k280q profile. Can anyone verify this bug/feature ? M.C>
Hello.

There is probably bug/feature in drivers 352.83/354.80 (on Grid K2).
Frame rate limiter (enabled by default with frame_rate_limiter 1/frl_config 0x3C) limits at 70 FPS instead of expected 60 FPS. Tested with Heaven benchmark and windowed lowres @ k280q profile.
Can anyone verify this bug/feature ?

M.C>

#1
Posted 03/05/2016 01:03 PM   
Hi MC, I'm checking with the dev/test team. I hope someone will respond rapidly. Many thanks for raising this and including the specific driver details - helpful as always! Rachel
Hi MC,

I'm checking with the dev/test team. I hope someone will respond rapidly.

Many thanks for raising this and including the specific driver details - helpful as always!

Rachel

#2
Posted 03/07/2016 09:10 AM   
Hi MArtin, Apparently it's a bit like a car speedo! There's a bit of a margin in there to guarantee to some sigma you always get 60fps; so in practice may see 65-68fps depending on what you are doing... Best wishes, Rachel
Hi MArtin,

Apparently it's a bit like a car speedo! There's a bit of a margin in there to guarantee to some sigma you always get 60fps; so in practice may see 65-68fps depending on what you are doing...

Best wishes,
Rachel

#3
Posted 03/17/2016 08:38 PM   
Ok, feature. Thanks, M.C>
Ok, feature.
Thanks, M.C>

#4
Posted 03/18/2016 07:22 AM   
Passthrough mode is, I believe, unlimited.
Passthrough mode is, I believe, unlimited.

-=Tobias

#5
Posted 05/08/2016 11:28 PM   
Hi, I am also experiencing problems with this. When I use my K2 GRID board in vGPU mode with any profiles, my image generator (diamond visionic Genesis RTX) starts generating 63-66 frames per second (really not stable) which results in very poor image performance on any PCoIP session that is asking for 60 FPS. Live Statistics from the IG itself shows the swapbuffer very unstable and being all over the place which in turn affects the round trip. I have isolated this problem at the GRID software level since using the K2 in passthrough mode directly to the VM gives me a perfect and stable 60 FPS as well as a consistent swapbuffer and round trip which results in a much better user experience. Is there a way at the GRID GPU Manager level to lock the synch down to 60HZ? Thanks Pascal
Hi,

I am also experiencing problems with this. When I use my K2 GRID board in vGPU mode with any profiles, my image generator (diamond visionic Genesis RTX) starts generating 63-66 frames per second (really not stable) which results in very poor image performance on any PCoIP session that is asking for 60 FPS.

Live Statistics from the IG itself shows the swapbuffer very unstable and being all over the place which in turn affects the round trip. I have isolated this problem at the GRID software level since using the K2 in passthrough mode directly to the VM gives me a perfect and stable 60 FPS as well as a consistent swapbuffer and round trip which results in a much better user experience.

Is there a way at the GRID GPU Manager level to lock the synch down to 60HZ?

Thanks

Pascal

#6
Posted 06/08/2016 08:10 PM   
Hi Pascal, Could you try using vsync and report if that improves things. Sampling at exactly 60 against a slightly faster source code can cause stutter. I'm not sure if vsync will suffer from the same issue though but it's worth trying. I'll also report this to the product team. I'm slightly surprised I haven't heard this before as we have lots of PCoIP and VMware users... I'm wondering if there is a way to configure PCoIP to avoid ?!? Best wishes, Rachel
Hi Pascal,

Could you try using vsync and report if that improves things. Sampling at exactly 60 against a slightly faster source code can cause stutter. I'm not sure if vsync will suffer from the same issue though but it's worth trying.

I'll also report this to the product team. I'm slightly surprised I haven't heard this before as we have lots of PCoIP and VMware users... I'm wondering if there is a way to configure PCoIP to avoid ?!?

Best wishes,
Rachel

#7
Posted 06/09/2016 12:29 PM   
Hi Rachel, thanks for your reply. I already tried using the vsync and it doesnt really change anything. I dont think this is an issue with the PCoIP itself but rather between the GPU, NVIDIA GRID Software and the Vritual Machine. Somehow, the GRID software seems to configure the GPU on a VM to generate higher than 60 FPS and my image generator doesnt like that. in vDGA mode where the GRID software is not a factor, I get a perfect 60FPS and stable at the IG level (through a PCoIP session). I will try to use an IG from a different manufacturer to see if I get the same issue. Maybe the Genesis IG doesnt handle oversampling and are configured for 30, 60 and 120 FPS exactly.
Hi Rachel,

thanks for your reply.

I already tried using the vsync and it doesnt really change anything.

I dont think this is an issue with the PCoIP itself but rather between the GPU, NVIDIA GRID Software and the Vritual Machine. Somehow, the GRID software seems to configure the GPU on a VM to generate higher than 60 FPS and my image generator doesnt like that.

in vDGA mode where the GRID software is not a factor, I get a perfect 60FPS and stable at the IG level (through a PCoIP session). I will try to use an IG from a different manufacturer to see if I get the same issue. Maybe the Genesis IG doesnt handle oversampling and are configured for 30, 60 and 120 FPS exactly.

#8
Posted 06/09/2016 01:20 PM   
Hi Pascal, What is the FPS you are seing on pass-through (there is no FRL) so I would expect it to be considerably higher can you check that. I am not an expert and have asked colleagues and have a split of opinion, some believe vsync should solve this and asked me to check you really had enabled it, he advised: "User can enable VSYNC to be forced ON in the NVIDIA control panel and that will sync the rendering rate to 60Hz or 60FPS. What I would have expected would have been a higher FPS for pass-through with identical settings. Confirm the VSYNC settings in the two VMs are identical (VSYNC=ON) in the global defaults. Also an important detail is that changes to the settings in the NVIDIA control panel on take effect for new processes. If the setting was changed while the application was running it will continue to use the settings that were made at the initial process launch. Ensure the user is aware of this limitation." Could you double check? Is there no difference at all with vSync / slightly better/slightly worse. As I said conflicting thoughts as to whether vsync could be showing jitter and some repro needed htis side - I'm just trying to get you quick ideas. Rachel
Hi Pascal,

What is the FPS you are seing on pass-through (there is no FRL) so I would expect it to be considerably higher can you check that.

I am not an expert and have asked colleagues and have a split of opinion, some believe vsync should solve this and asked me to check you really had enabled it, he advised:

"User can enable VSYNC to be forced ON in the NVIDIA control panel and that will sync the rendering rate to 60Hz or 60FPS. What I would have expected would have been a higher FPS for pass-through with identical settings.

Confirm the VSYNC settings in the two VMs are identical (VSYNC=ON) in the global defaults.
Also an important detail is that changes to the settings in the NVIDIA control panel on take effect for new processes. If the setting was changed while the application was running it will continue to use the settings that were made at the initial process launch. Ensure the user is aware of this limitation."

Could you double check? Is there no difference at all with vSync / slightly better/slightly worse. As I said conflicting thoughts as to whether vsync could be showing jitter and some repro needed htis side - I'm just trying to get you quick ideas.

Rachel

#9
Posted 06/09/2016 03:58 PM   
Scroll To Top

Add Reply