Artificial Intelligence Computing Leadership from NVIDIA
Horizon - Video playback performance
Hi Simon, so I ran this command on the hypervisor to set the best effort scheduler and rebooted the hosts: esxcli system module parameters set -m nvidia -p "NVreg_RegistryDwords=RmPVMRL=0x00" But I dont see any difference. The frame rates are still way to high. The question is, on which layer the problem occurs first. It can be the hypervisor, the VM config, the Guest OS or the NVIDIA driver on the OS. So i set the preference on the lowest layer, which should be fine. I read the installation manual multiple times and I cant figure out any config errors done by me. I have to correct that we are now on ESXi 6.5U2, maybe there is a known bug or problem? We are on the latest GRID 6.1 software (host driver version: 390.57). UPDATE: I did further investigation and noticed a very interesting benchmark behaviour. This was tested with the Unigine Valley Benchmark. While the benchmark is running, the FPS-Counter in the application tells, that you are almost fixed at 67/68 sometimes 70FPS, while the hypervisor (nvidia-smi vgpu -es) tells you this: # GPU vGPU Session Process Codec H V Average Average # Idx Id Id Id Type Res Res FPS Latency(us) 0 311288 7 2256 H.264 1920 1080 140 901 0 311288 8 2256 H.264 1920 1080 7 161 0 311288 7 2256 H.264 1920 1080 102 984 0 311288 8 2256 H.264 1920 1080 7 303 0 311288 7 2256 H.264 1920 1080 94 785 0 311288 8 2256 H.264 1920 1080 7 202 0 311288 7 2256 H.264 1920 1080 104 773 0 311288 8 2256 H.264 1920 1080 7 673 0 311288 7 2256 H.264 1920 1080 103 875 0 311288 8 2256 H.264 1920 1080 7 333 0 311288 7 2256 H.264 1920 1080 107 823 0 311288 8 2256 H.264 1920 1080 7 154 0 311288 7 2256 H.264 1920 1080 125 792 0 311288 8 2256 H.264 1920 1080 7 421 0 311288 7 2256 H.264 1920 1080 125 790 0 311288 8 2256 H.264 1920 1080 7 1096 0 311288 7 2256 H.264 1920 1080 87 759 0 311288 8 2256 H.264 1920 1080 2010 152 0 311288 7 2256 H.264 1920 1080 109 835 0 311288 8 2256 H.264 1920 1080 7 184 The benchmark feels like the frames are dropping very hard, but the FPS-Counter and the hypervisor tells you, that there are no frame-drops at all. Where/what can be the cause of this odd behaviour? ANOTHER UPDATE: I imported the View GPOs and set the MaxFPS-Blast GPO to 60 fps. It feels much much smoother now, but the frame rates are still pretty high and you can feel some sort of "lag" if you move windows quick or even in some video sequences, but no comparison to before (Max 30 FPS). So I think the main problem is found and stupid simple. But for the fine tuning and the problem with the high fps I would be very pleased if I get further help here. Thank you for your helpful advice and effort! Regards, Dominik
Hi Simon,

so I ran this command on the hypervisor to set the best effort scheduler and rebooted the hosts:
esxcli system module parameters set -m nvidia -p "NVreg_RegistryDwords=RmPVMRL=0x00"

But I dont see any difference. The frame rates are still way to high.
The question is, on which layer the problem occurs first.
It can be the hypervisor, the VM config, the Guest OS or the NVIDIA driver on the OS.
So i set the preference on the lowest layer, which should be fine.
I read the installation manual multiple times and I cant figure out any config errors done by me.
I have to correct that we are now on ESXi 6.5U2, maybe there is a known bug or problem?
We are on the latest GRID 6.1 software (host driver version: 390.57).

UPDATE: I did further investigation and noticed a very interesting benchmark behaviour. This was tested with the Unigine Valley Benchmark. While the benchmark is running, the FPS-Counter in the application tells, that you are almost fixed at 67/68 sometimes 70FPS, while the hypervisor (nvidia-smi vgpu -es) tells you this:

# GPU vGPU Session Process Codec H V Average Average
# Idx Id Id Id Type Res Res FPS Latency(us)
0 311288 7 2256 H.264 1920 1080 140 901
0 311288 8 2256 H.264 1920 1080 7 161
0 311288 7 2256 H.264 1920 1080 102 984
0 311288 8 2256 H.264 1920 1080 7 303
0 311288 7 2256 H.264 1920 1080 94 785
0 311288 8 2256 H.264 1920 1080 7 202
0 311288 7 2256 H.264 1920 1080 104 773
0 311288 8 2256 H.264 1920 1080 7 673
0 311288 7 2256 H.264 1920 1080 103 875
0 311288 8 2256 H.264 1920 1080 7 333
0 311288 7 2256 H.264 1920 1080 107 823
0 311288 8 2256 H.264 1920 1080 7 154
0 311288 7 2256 H.264 1920 1080 125 792
0 311288 8 2256 H.264 1920 1080 7 421
0 311288 7 2256 H.264 1920 1080 125 790
0 311288 8 2256 H.264 1920 1080 7 1096
0 311288 7 2256 H.264 1920 1080 87 759
0 311288 8 2256 H.264 1920 1080 2010 152
0 311288 7 2256 H.264 1920 1080 109 835
0 311288 8 2256 H.264 1920 1080 7 184

The benchmark feels like the frames are dropping very hard, but the FPS-Counter and the hypervisor tells you, that there are no frame-drops at all. Where/what can be the cause of this odd behaviour?

ANOTHER UPDATE: I imported the View GPOs and set the MaxFPS-Blast GPO to 60 fps. It feels much much smoother now, but the frame rates are still pretty high and you can feel some sort of "lag" if you move windows quick or even in some video sequences, but no comparison to before (Max 30 FPS).

So I think the main problem is found and stupid simple.
But for the fine tuning and the problem with the high fps I would be very pleased if I get further help here.

Thank you for your helpful advice and effort!

Regards,
Dominik

#16
Posted 06/18/2018 07:44 AM   
What are the min QP and max QP settings in the Blast Extreme session? And are you using UDP or TCP?
What are the min QP and max QP settings in the Blast Extreme session?
And are you using UDP or TCP?

#17
Posted 07/05/2018 06:22 PM   
[quote=""]What are the min QP and max QP settings in the Blast Extreme session? And are you using UDP or TCP?[/quote] The QP settings are the default ones. We tried UDP and TCP, but there is no noticeable difference. I dont think, that this problem is a Blast setting. My guess is, that the frame rate limiter on the hypervisor is not working correctly. Blast displays only 60FPS due to the GPO I set, but the hypervisor renders way more frames than this. This is very bad for the user experience and of course also the user density, since one user could claim nearly all the performance of that physical GPU.
said:What are the min QP and max QP settings in the Blast Extreme session?
And are you using UDP or TCP?


The QP settings are the default ones. We tried UDP and TCP, but there is no noticeable difference. I dont think, that this problem is a Blast setting. My guess is, that the frame rate limiter on the hypervisor is not working correctly. Blast displays only 60FPS due to the GPO I set, but the hypervisor renders way more frames than this. This is very bad for the user experience and of course also the user density, since one user could claim nearly all the performance of that physical GPU.

#18
Posted 07/09/2018 06:07 AM   
Hi Prinz, I disagree. Let's discuss this offline. Please send me a PM. regards Simon
Hi Prinz,

I disagree. Let's discuss this offline. Please send me a PM.

regards

Simon

#19
Posted 07/09/2018 06:46 AM   
I'm having the same results as others on this forum with Horizon blast (7.7) stuttering playback with H264 encoding enabled. We are using P40 cards, using 4Q and grid driver 412.16. Was this ever resolved?
I'm having the same results as others on this forum with Horizon blast (7.7) stuttering playback with H264 encoding enabled. We are using P40 cards, using 4Q and grid driver 412.16. Was this ever resolved?

#20
Posted 01/26/2019 02:06 AM   
This sounds similar to my issue.
This sounds similar to my issue.

#21
Posted 03/04/2019 03:14 PM   
Any solution? I have the same issue
Any solution?
I have the same issue

#22
Posted 03/19/2019 03:32 PM   
We discussed the "issue" offline, but it seems that this is the normal behaviour in a VMware Horiozon environment. This kind of issue does not exist in Citrix XenDesktop. The video playback performance is still not as smooth as on a physical workstation, but it fits out needs. Even when using the H.265 enocoding, which was introduced in the new Horizon Client (i think, V.5.0), the performance is the same. To clear this up: There is no fix for this issue, because it is normal behaviour. Lets hope, that there will be a patch so that the performance (specific for the video playback) increases.
We discussed the "issue" offline, but it seems that this is the normal behaviour in a VMware Horiozon environment. This kind of issue does not exist in Citrix XenDesktop. The video playback performance is still not as smooth as on a physical workstation, but it fits out needs. Even when using the H.265 enocoding, which was introduced in the new Horizon Client (i think, V.5.0), the performance is the same.

To clear this up: There is no fix for this issue, because it is normal behaviour.
Lets hope, that there will be a patch so that the performance (specific for the video playback) increases.

#23
Posted 05/21/2019 09:11 AM   
Exactly the same issue here. We use ESXi 6.7 P01 (latest patches), nvidia grid driver version 442.06, Horizon View 7.10 - but still the same issue. Does anybody know, if something does the "trick", meanwhile?
Exactly the same issue here.
We use ESXi 6.7 P01 (latest patches), nvidia grid driver version 442.06, Horizon View 7.10 - but still the same issue.

Does anybody know, if something does the "trick", meanwhile?

#24
Posted 02/21/2020 11:22 PM   
Scroll To Top

Add Reply