Artificial Intelligence Computing Leadership from NVIDIA
Mouse performance in Citrix/Blast virtual desktops running vGPU
Hi, This isn't a specific question about GRID performance but thought it may have cropped up given the use of 4K panels and Q profiles running GRID. We use predominantly P6-XX profiles, but the mouse behaviour remains consistently slow at higher res. I've also posted a similar question elsewhere (VMware forum, Citrix, etc.) I've been working with Horizon virtualisation for a while now and over the past few months more and more clients we work with are looking into 4K panels. I notice that using mid-range resolutions such as 1920x1200 and even 2560x1600 we see a fairly performant desktop, certainly with regard to mouse responsiveness. However, upping resolution to 4K, the mouse performance degrades. The responsiveness is the problem, where you feel you are dragging the mouse/window rather than pushing it. I can't measure the lag, but the instant response is not there. This occurs irrespective of protocol (HDX, PCoIP, Blast) and is linked to higher resolutions. We see this with vGPU accelerated and standard desktops - there is no load on the CPU host-side, and the network bandwidth is practically idle - it just appears to be a general lag. Endpoints are a mix of Intel NUC, PCoIP Tera 2 zero clients, Windows 10 laptops, HP/Zotac/Dell thin clients. It makes sense that there is more pixels to cross for the same mouse/hand movement with 4K compared to UHD, but I having looked at the mouse options, such as increasing the speed of the cursor, this doesn't translate when moving window, etc. I've also tried this on a 30Hz and 60Hz panel with the same results. Does anyone else feel this or have any options that could improve the feel? Thanks
Hi,

This isn't a specific question about GRID performance but thought it may have cropped up given the use of 4K panels and Q profiles running GRID. We use predominantly P6-XX profiles, but the mouse behaviour remains consistently slow at higher res. I've also posted a similar question elsewhere (VMware forum, Citrix, etc.)

I've been working with Horizon virtualisation for a while now and over the past few months more and more clients we work with are looking into 4K panels. I notice that using mid-range resolutions such as 1920x1200 and even 2560x1600 we see a fairly performant desktop, certainly with regard to mouse responsiveness. However, upping resolution to 4K, the mouse performance degrades. The responsiveness is the problem, where you feel you are dragging the mouse/window rather than pushing it. I can't measure the lag, but the instant response is not there. This occurs irrespective of protocol (HDX, PCoIP, Blast) and is linked to higher resolutions. We see this with vGPU accelerated and standard desktops - there is no load on the CPU host-side, and the network bandwidth is practically idle - it just appears to be a general lag. Endpoints are a mix of Intel NUC, PCoIP Tera 2 zero clients, Windows 10 laptops, HP/Zotac/Dell thin clients.

It makes sense that there is more pixels to cross for the same mouse/hand movement with 4K compared to UHD, but I having looked at the mouse options, such as increasing the speed of the cursor, this doesn't translate when moving window, etc.

I've also tried this on a 30Hz and 60Hz panel with the same results. Does anyone else feel this or have any options that could improve the feel?

Thanks

#1
Posted 06/20/2018 12:37 PM   
Hello, Have you tried with VMware Tools 10.3.10 ? In the resolve issues, there's something related to mouse
Hello,

Have you tried with VMware Tools 10.3.10 ? In the resolve issues, there's something related to mouse

#2
Posted 09/03/2019 10:00 AM   
Have you tried setting max FPS to 60?
Have you tried setting max FPS to 60?

#3
Posted 09/04/2019 11:05 AM   
Scroll To Top

Add Reply