NVIDIA
Hide Nvidia tray icon
Hello, We are trying to hide the nVidia Tray icon and the shell icon (right click desktop). I can disable it on the server through the application, however that's user based. With RegShot I've found out it uses the keys: HKCU\Software\NVIDIA Corporation\NvTray\StartOnLogin HKCU\Software\NVIDIA Corporation\Global\NvCplApi\Policies\ContextUIPolicy When disabled they have a value of 0. However both using these keys with value 0 to a users profile does not hide them, nor does adding them to HKLM work. Our users get very confused (I know right) with a new icon and would like it to be hidden. Can you tell me another way to hide it for everyone? Thanks.
Hello,

We are trying to hide the nVidia Tray icon and the shell icon (right click desktop). I can disable it on the server through the application, however that's user based.

With RegShot I've found out it uses the keys:
HKCU\Software\NVIDIA Corporation\NvTray\StartOnLogin
HKCU\Software\NVIDIA Corporation\Global\NvCplApi\Policies\ContextUIPolicy

When disabled they have a value of 0. However both using these keys with value 0 to a users profile does not hide them, nor does adding them to HKLM work.

Our users get very confused (I know right) with a new icon and would like it to be hidden. Can you tell me another way to hide it for everyone?

Thanks.

#1
Posted 07/04/2018 02:22 PM   
Hi, could you please try the following for the NVTray Icon: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvlddmkm\NvTray] "StartOnLogin"=dword:00000000 Regards Simon
Hi,

could you please try the following for the NVTray Icon:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvlddmkm\NvTray]
"StartOnLogin"=dword:00000000

Regards

Simon

#2
Posted 07/04/2018 03:22 PM   
Great, the tray icon is hidden now. However the "nView Desktop Manager" still shows when users right click the desktop. What way should we use to go around that? I've already tried removing the option from the registry: HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\NvCplDesktopContext However after a reboot it's back.
Great, the tray icon is hidden now. However the "nView Desktop Manager" still shows when users right click the desktop. What way should we use to go around that?

I've already tried removing the option from the registry:
HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\NvCplDesktopContext

However after a reboot it's back.

#3
Posted 07/05/2018 08:16 AM   
Hi I covered this a while back, here's a link to my post, it should do what you're after ... [url]https://gridforums.nvidia.com/default/topic/1190/restrict-nvidia-control-panel-setting-changes-via-group-policy-or-registry-/?offset=2#4407[/url] For persistence, just use a GPO. Regards Ben
Hi

I covered this a while back, here's a link to my post, it should do what you're after ...

https://gridforums.nvidia.com/default/topic/1190/restrict-nvidia-control-panel-setting-changes-via-group-policy-or-registry-/?offset=2#4407

For persistence, just use a GPO.

Regards

Ben

#4
Posted 07/09/2018 08:04 AM   
Thanks for sharing Ben. Nice idea to just hide :) Regards Simon
Thanks for sharing Ben.
Nice idea to just hide :)

Regards

Simon

#5
Posted 07/09/2018 02:44 PM   
Is there anything else you can do to hide the tray Icon in driver version 391.81? The registry key above does not seem to work. This is causing a major issue at the moment where the task tray icon is launching with Autodesk products. It does not close when the user exits the virtual application. Leaving the session open and causing interruptions when they cannot launch the app again because the session is still running.
Is there anything else you can do to hide the tray Icon in driver version 391.81? The registry key above does not seem to work. This is causing a major issue at the moment where the task tray icon is launching with Autodesk products. It does not close when the user exits the virtual application. Leaving the session open and causing interruptions when they cannot launch the app again because the session is still running.

#6
Posted 09/07/2018 08:52 PM   
Scroll To Top

Add Reply