NVIDIA
Tesla M10 Card not working XenApp 7.18
Recently deployed a Tesla M10 in passthrough mode on a Citrix XenApp 7.18 Windows 2016 platform using vSPhere as the hypervisor. The Nvidia drivers are installed and the card is displaying in Device Manager and in the Nvidia driver app. Yet the card doesn't seem to be handling any of the Graphics processing. CPU usage still spykes when running youtube videos. The machine uses the exact same resources as a machine without a GPU attached. We have vAPPS licenses, but I could not specify the license server in the Nvidia control panel, it's greyed out. I'm new to the deployment of using graphics cards, am I missing something? Is there something I can check.
Recently deployed a Tesla M10 in passthrough mode on a Citrix XenApp 7.18 Windows 2016 platform using vSPhere as the hypervisor. The Nvidia drivers are installed and the card is displaying in Device Manager and in the Nvidia driver app.

Yet the card doesn't seem to be handling any of the Graphics processing. CPU usage still spykes when running youtube videos. The machine uses the exact same resources as a machine without a GPU attached. We have vAPPS licenses, but I could not specify the license server in the Nvidia control panel, it's greyed out.

I'm new to the deployment of using graphics cards, am I missing something? Is there something I can check.
Attachments

Desktop Viewer.jpg

#1
Posted 10/04/2018 05:20 PM   
Most likely you did not configure the local policy to use the GPU for RDS sessions: *snip* On Windows Server 2012, Remote Desktop Services (RDS) sessions on the RD Session Host server use the Microsoft Basic Render Driver as the default adapter. To use the GPU in RDS sessions on Windows Server 2012, enable the Use the hardware default graphics adapter for all Remote Desktop Services sessions setting in the group policy Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Remote Session Environment. *snip*
Most likely you did not configure the local policy to use the GPU for RDS sessions:
*snip*
On Windows Server 2012, Remote Desktop Services (RDS) sessions on the RD Session Host server use the Microsoft Basic Render Driver as the default adapter. To use the GPU in RDS sessions on Windows Server 2012, enable the Use the hardware default graphics adapter for all Remote Desktop Services sessions setting in the group policy Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Remote Session Environment.
*snip*

#2
Posted 10/05/2018 12:24 PM   
You should be using vGPU not Passthrough, especially with VMware! Because of the way in which VMware handles Passthrough devices, you need to allocate the specific PCIe / hardware address of the M10's GPU that you want to use. Whereas with vGPU, the system will automatically decide which of the M10s 4x GPUs it will use, or if you have 2x M10s available, which of the 8x GPUs it will use. So with a single M10 using Passthrough, your VM will only ever use [u]1[/u] of the 4 GPUs. With vGPU, your VM will use [u]any[/u] of the 4 GPUs on the M10. vGPU is much more flexible and easier to manage than Passthrough, especially as VMware requires a reboot to switch between Passthrough and vGPU. You're also missing out on vMotion capabilites and other features only available with vGPU. If you decide to change to use vGPU, make sure you have the vGPU Manager installed in your VMware host. Passthrough doesn't need it, so you may not have already installed it. If you were using XenServer, it wouldn't matter so much as it handles Passthrough in a different way. Not that I'm promoting XenServer, I'm just highlighting one of the differences in the way in which GPUs are handled. Secondly, when specifying a GRID License, by far the easiest way to do it is using Group Policy: [url]https://docs.nvidia.com/grid/latest/grid-licensing-user-guide/index.html#windows-registry-grid-license-settings[/url] For the reason your GPU isn't currently being used, refer to Simons post above.
You should be using vGPU not Passthrough, especially with VMware! Because of the way in which VMware handles Passthrough devices, you need to allocate the specific PCIe / hardware address of the M10's GPU that you want to use. Whereas with vGPU, the system will automatically decide which of the M10s 4x GPUs it will use, or if you have 2x M10s available, which of the 8x GPUs it will use. So with a single M10 using Passthrough, your VM will only ever use 1 of the 4 GPUs. With vGPU, your VM will use any of the 4 GPUs on the M10. vGPU is much more flexible and easier to manage than Passthrough, especially as VMware requires a reboot to switch between Passthrough and vGPU. You're also missing out on vMotion capabilites and other features only available with vGPU.

If you decide to change to use vGPU, make sure you have the vGPU Manager installed in your VMware host. Passthrough doesn't need it, so you may not have already installed it.

If you were using XenServer, it wouldn't matter so much as it handles Passthrough in a different way. Not that I'm promoting XenServer, I'm just highlighting one of the differences in the way in which GPUs are handled.

Secondly, when specifying a GRID License, by far the easiest way to do it is using Group Policy: https://docs.nvidia.com/grid/latest/grid-licensing-user-guide/index.html#windows-registry-grid-license-settings

For the reason your GPU isn't currently being used, refer to Simons post above.

#3
Posted 10/08/2018 08:02 AM   
Scroll To Top

Add Reply