NVIDIA
Nvidia Tesla M10 - Artifacts on RDS servers
We have a client with three hosts, each with a Nvidia Tesla M10 videocard and a cluster of 12 Remote Desktop servers. (4 machines per host). The RDS servers each have their own card, Direct shared from VMWare. Installed the new 392.05 driver in Windows. We have 2 policies active on the hosts: * SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\AVC444ModePreferred (1) *enabled* * Policy Setting Comment Use the hardware default graphics adapter for all Remote Desktop Services sessions *enabled* When using video inside the RDS sessions, we're seeing artifacts happening. What do we have to set to keep these from happening? Video of the artifacts: https://drive.google.com/file/d/1wNW9Y3cAJCmVUnHt96anrd2dNiyJi9MJ/view?usp=sharing
We have a client with three hosts, each with a Nvidia Tesla M10 videocard and a cluster of 12 Remote Desktop servers. (4 machines per host).
The RDS servers each have their own card, Direct shared from VMWare.
Installed the new 392.05 driver in Windows.
We have 2 policies active on the hosts:

* SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\AVC444ModePreferred (1) *enabled*

* Policy Setting Comment
Use the hardware default graphics adapter for all Remote Desktop Services sessions *enabled*

When using video inside the RDS sessions, we're seeing artifacts happening.
What do we have to set to keep these from happening?

Video of the artifacts:
https://drive.google.com/file/d/1wNW9Y3cAJCmVUnHt96anrd2dNiyJi9MJ/view?usp=sharing

#1
Posted 10/16/2018 12:24 PM   
Hi, in the video I see screen flickering and no artifacts. Are you running fullscreen or window mode? Please check your policies once again: *snip* Policy Editor (gpedit.msc) under Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Remote Session Environment: 1. Prioritize H.264/AVC 444 Graphics mode for Remote Desktop connections When enabled on the RDP Server, the H.264/AVC 444 mode will be prioritized when the RDP 10 client and server both support AVC/H.264 and support the AVC 444 mode. Note: For Remote Desktop Session Host (RDSH) environments only full desktop sessions are supported with H.264/AVC 444, RemoteApp sessions still use the proprietary codecs for now. 2. Configure H.264/AVC hardware encoding for Remote Desktop connections This policy lets you enable hardware encoding for AVC/H.264, when used in conjunction with the AVC444 mode. When enabled, each remote desktop monitor will use up one AVC/H.264 encoder on the server. If all AVC/H.264 encoders are in use, the RDP Server will automatically fallback to using Software. How to determine if a Remote Desktop session is using AVC444 mode and is using hardware encoding RDP logs an event to the eventlog which helps to determine if you are running in the AVC 444 mode and whether Hardware Encoding is used: Launch the Event Viewer in Windows on the RDP server and navigate to the following node: Applications and Services Logs -> Microsoft -> Windows -> RemoteDesktopServices-RdpCoreTS To determine if AVC 444 mode is used, look for Event ID 162, if “AVC Available: 1 Initial Profile: 2048” than AVC 444 is used. *snip* regards Simon
Hi,

in the video I see screen flickering and no artifacts. Are you running fullscreen or window mode?

Please check your policies once again:
*snip*
Policy Editor (gpedit.msc) under Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Remote Session Environment:
1. Prioritize H.264/AVC 444 Graphics mode for Remote Desktop connections
When enabled on the RDP Server, the H.264/AVC 444 mode will be prioritized when the RDP 10 client and server both support AVC/H.264 and support the AVC 444 mode. Note: For Remote Desktop Session Host (RDSH) environments only full desktop sessions are supported with H.264/AVC 444, RemoteApp sessions still use the proprietary codecs for now.
2. Configure H.264/AVC hardware encoding for Remote Desktop connections
This policy lets you enable hardware encoding for AVC/H.264, when used in conjunction with the AVC444 mode. When enabled, each remote desktop monitor will use up one AVC/H.264 encoder on the server. If all AVC/H.264 encoders are in use, the RDP Server will automatically fallback to using Software.
How to determine if a Remote Desktop session is using AVC444 mode and is using hardware encoding
RDP logs an event to the eventlog which helps to determine if you are running in the AVC 444 mode and whether Hardware Encoding is used:
Launch the Event Viewer in Windows on the RDP server and navigate to the following node:
Applications and Services Logs -> Microsoft -> Windows -> RemoteDesktopServices-RdpCoreTS
To determine if AVC 444 mode is used, look for Event ID 162, if “AVC Available: 1 Initial Profile: 2048” than AVC 444 is used.
*snip*


regards

Simon

#2
Posted 10/16/2018 01:53 PM   
The problem might be better visable in this example video. https://drive.google.com/file/d/120PFPdYGr-92eEXe1WptXpUsldNUqWNn/view?usp=sharing I'll review the policy settings and update this ticket once I get some results.
The problem might be better visable in this example video.


https://drive.google.com/file/d/120PFPdYGr-92eEXe1WptXpUsldNUqWNn/view?usp=sharing


I'll review the policy settings and update this ticket once I get some results.

#3
Posted 10/18/2018 12:43 PM   
Hi, now I have seen it :) This looks awful and I've never seen something like this in conjunction with GPU. Could you also test with another (previous 391.81) driver just to make sure it is not driver related? But I would assume that something else is going on here. Regards Simon
Hi,

now I have seen it :)
This looks awful and I've never seen something like this in conjunction with GPU.
Could you also test with another (previous 391.81) driver just to make sure it is not driver related?
But I would assume that something else is going on here.

Regards

Simon

#4
Posted 10/18/2018 05:12 PM   
Hi Simon, Thanks for your assistance. The issue remained, even after reviewing the policies. We also see this in the eventlog (in Dutch): "De client ondersteunt versie 0xA0200 van het RDP Graphics-protocol, clientmodus: 0, AVC beschikbaar: 1. Oorspronkelijk profiel: 2048 Server: RDS12" I've installed 391.81 and asked the client to test. Kind regards, Jarno
Hi Simon,

Thanks for your assistance.
The issue remained, even after reviewing the policies.
We also see this in the eventlog (in Dutch):
"De client ondersteunt versie 0xA0200 van het RDP Graphics-protocol, clientmodus: 0, AVC beschikbaar: 1. Oorspronkelijk profiel: 2048 Server: RDS12"

I've installed 391.81 and asked the client to test.

Kind regards,

Jarno

#5
Posted 11/03/2018 09:18 AM   
Hi Jarno, you should contact someone from MSFT. I'm pretty sure this is a remoting issue and has nothing to do with the GPU if you see GPU load. regards Simon
Hi Jarno,

you should contact someone from MSFT. I'm pretty sure this is a remoting issue and has nothing to do with the GPU if you see GPU load.

regards

Simon

#6
Posted 11/04/2018 08:35 AM   
Too bad, with previous driver there is an issue too, as you can see in this video: https://drive.google.com/file/d/1qLviYZcMtX_3G-9tcTgj16tMzM1OBYVZ/view?usp=sharing Tested with 1 user on the RDS server by the way. Eventlog message (in Dutch again): De client ondersteunt versie 0xA0200 van het RDP Graphics-protocol, clientmodus: 0, AVC beschikbaar: 1. Oorspronkelijk profiel: 2048 Server: RDS12 Coderingsprogramma voor AVC-hardware ingeschakeld: 1, naam van coderingsprogramma is NVIDIA H.264 Encoder MFT. Server: RDS12
Too bad, with previous driver there is an issue too, as you can see in this video:


https://drive.google.com/file/d/1qLviYZcMtX_3G-9tcTgj16tMzM1OBYVZ/view?usp=sharing


Tested with 1 user on the RDS server by the way.

Eventlog message (in Dutch again):
De client ondersteunt versie 0xA0200 van het RDP Graphics-protocol, clientmodus: 0, AVC beschikbaar: 1. Oorspronkelijk profiel: 2048 Server: RDS12
Coderingsprogramma voor AVC-hardware ingeschakeld: 1, naam van coderingsprogramma is NVIDIA H.264 Encoder MFT. Server: RDS12

#7
Posted 11/06/2018 02:59 PM   
Scroll To Top

Add Reply