NVIDIA
ESXi VIB packaging feature request
Currently when installation of the GRID ESXi VIB completes ESXi reports that no reboot is required. However, both the documentation and experimental evidence show this is required. For future releases, would it be possible to include the reboot required flag when the vib is packaged? Thanks.
Currently when installation of the GRID ESXi VIB completes ESXi reports that no reboot is required. However, both the documentation and experimental evidence show this is required. For future releases, would it be possible to include the reboot required flag when the vib is packaged?

Thanks.

#1
Posted 09/01/2016 04:29 PM   
Thanks for raising this Jeremy. I've asked the Product managers and engineers at both NVIDIA and VMware to check and update if needed. Many thanks for the feedback - we do listen :-D Rachel
Thanks for raising this Jeremy.

I've asked the Product managers and engineers at both NVIDIA and VMware to check and update if needed.

Many thanks for the feedback - we do listen :-D

Rachel

#2
Posted 09/02/2016 12:50 PM   
Hi Jeremy, I've spoken to our architects the flag is set according to advice from VMware architects (who we've also spoken to) to avoid interfering with certain PXE boot and similar workflows. VMware engineering advice continues to be that the flag is set appropriately and a reboot should not be necessary. If you are finding a reboot is necessary you should raise a support ticket with VMware frontline, you can direct them to this thread and advise them in the event of questions to contact VMWare GRID product management who have been made aware of this inquiry. Do let us know how this progresses. Many thanks, Rachel
Hi Jeremy,

I've spoken to our architects the flag is set according to advice from VMware architects (who we've also spoken to) to avoid interfering with certain PXE boot and similar workflows. VMware engineering advice continues to be that the flag is set appropriately and a reboot should not be necessary. If you are finding a reboot is necessary you should raise a support ticket with VMware frontline, you can direct them to this thread and advise them in the event of questions to contact VMWare GRID product management who have been made aware of this inquiry.

Do let us know how this progresses.

Many thanks,
Rachel

#3
Posted 09/02/2016 04:10 PM   
Please do also let us know of any NVIDIA documentation that you find is confusing/conflicting and we'll look to have it clarified. Rachel
Please do also let us know of any NVIDIA documentation that you find is confusing/conflicting and we'll look to have it clarified.

Rachel

#4
Posted 09/02/2016 04:12 PM   
Rachel, Thanks for checking internally as well as with VMware. Not having to reboot sounds great, hopefully I get that working. I updated both our GRID enabled servers when I did my updates. Both are test, so I can go back and redo this on one of those, but will be another day or two before I have time to do that. My experience at the time was that I could power on the VM after the upgrading the vib, until I restarted. Once I try this again, I'll get the exact error message to post here and reach out to VMware support. On the NVIDIA documentation, in the user-guide included with the VMware GRID software download, 367.43-369.17-nvidia-grid-vgpu-user-guide.pdf, in both sections 2.2.4.1 (installing) and 2.2.4.2 (updating) the final step listed is to reboot the host. Jeremy
Rachel,

Thanks for checking internally as well as with VMware. Not having to reboot sounds great, hopefully I get that working.

I updated both our GRID enabled servers when I did my updates. Both are test, so I can go back and redo this on one of those, but will be another day or two before I have time to do that. My experience at the time was that I could power on the VM after the upgrading the vib, until I restarted. Once I try this again, I'll get the exact error message to post here and reach out to VMware support.

On the NVIDIA documentation, in the user-guide included with the VMware GRID software download, 367.43-369.17-nvidia-grid-vgpu-user-guide.pdf, in both sections 2.2.4.1 (installing) and 2.2.4.2 (updating) the final step listed is to reboot the host.

Jeremy

#5
Posted 09/06/2016 08:30 PM   
Rachel, I was able to reproduce the reboot requirement when updating the VIB, I've opened service request 16239731009 with VMware with a reference to this thread and your note to contact VMware GRID product management. Jeremy
Rachel,

I was able to reproduce the reboot requirement when updating the VIB, I've opened service request 16239731009 with VMware with a reference to this thread and your note to contact VMware GRID product management.

Jeremy

#6
Posted 09/13/2016 07:17 PM   
An update for anyone who finds this later, I swapped emails with both VMware and NVIDIA, result was a statement that a reboot is required after updating the VIB. I reiterated a request that if that's the case, please package the VIB with that flag set.
An update for anyone who finds this later, I swapped emails with both VMware and NVIDIA, result was a statement that a reboot is required after updating the VIB. I reiterated a request that if that's the case, please package the VIB with that flag set.

#7
Posted 09/29/2016 06:46 PM   
Scroll To Top

Add Reply